Страницы: 1
RSS
Формула с заданными ограничениям
 
Добрый день, помогите, пожалуйста, решить задачку.

Логику максимально подробно описал в примере.
Изменено: Yeti_magic - 10.07.2024 20:24:36
 
Знаете, в Вашем прошлом файле суть задачи была понятнее, сейчас же совсем стало путанно) Имхо, Вам на самом деле не нужны значения общих заказов на производство - это вторичные (считайте, параметрические) данные. Основная строка - это как раз недельное производство (ну или подвоз в текущем примере) - на эти данные у Вас "завязаны" все расчеты. Вашу задачу нельзя решить формулами - здесь нужно применять поиск решения симплекс-методом с наложением ряда перечисленных условий. И если в последнюю неделю у Вас должно быть строго минимальное покрытие (1,5 - не более и не менее), то не во всех случаях решение может быть найдено.
 
Мне тоже кажется формулы не справятся. Спасибо Вам за внимание в любом случае!
 
Комментарий к условию. Формула в строке 7 чушь. Будет адекватно работать только при небольшом изменении расхода. В задаче значения могут изменяться практически вдвое - критерии обеспеченности с помощью такой формулы не будут выполнены.
 
Код
G5       =ЕСЛИОШИБКА(МАКС($C$14;1/(1/(ОКРУГЛВВЕРХ(МАКС(0;(G3+H3+I3+0,5*J3)-($C$4+СУММ($C$5:F5)-СУММ($C$3:G3)))/$C$15;0)*$C$15)));0)
H3:K3    =СМЕЩ($G$3;0;-(СТОЛБЕЦ()-СТОЛБЕЦ($G:$G)))
Страницы: 1
Наверх