Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Счет дней, часов..., необычный формат
 
Доброго времени суток! Как можно посчитать дни, часы, минуты и секунды в таком формате? Заренее всем спасибо
 
Что подразумеваете под фразой "посчитать дни, часы, минуты и секунды"? Подсчитать все вместе или отдельно дни, отдельно часы и т.д.? Если первое, то самое простое создать еще одни столбец, скопировать в него эти данные и: в первом столбец заменить(через Ctrl+H) "*д. " на пусто, а во втором наоборот "д. *" на пусто. Затем в третьем столбце все это сложить.
Если же надо все отдельно - то лучше макросом. Хотя можно и формулой(отдельной для каждой единицы измерения).
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Добрый день The_Prist! Да надо все отдельно. Но как для каждой единицы формулой?
 
Например так.
 
Если значения в диапазоне A3:A10.
Если сразу сумма значений:
Дни: =СУММ(ЕСЛИ(ЕОШ(ПОИСК("д.";A3:A10));0;--ПСТР(A3:A10;1;ПОИСК("д. ";A3:A10)-1)))
Часы: =СУММ(--ПСТР(A3:A10;ДЛСТР(A3:A10)-7;2))
Минуты: =СУММ(--ПСТР(A3:A10;ДЛСТР(A3:A10)-4;2))
Секунды: =СУММ(--ПСТР(A3:A10;ДЛСТР(A3:A10)-1;2))
Это все формулы массива.

Если просто раскидать по столбцам:
Дни: =ЕСЛИ(ЕОШ(ПОИСК("д.";A3));0;--ПСТР(A3;1;ПОИСК("д. ";A3)-1))
Часы: =--ПСТР(A3;ДЛСТР(A3)-7;2)
Минуты: =--ПСТР(A3;ДЛСТР(A3)-4;2)
Секунды: =--ПСТР(A3;ДЛСТР(A3)-1;2)
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
вы об этом?
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("д";D2));ЛЕВСИМВ(D2;ПОИСК("д";D2)+1);"")&" "&ПСТР(ПРАВСИМВ(D2;8);1;2)&"ч. "&ПСТР(ПРАВСИМВ(D2;8);4;2)&"мин. "&ПСТР(ПРАВСИМВ(D2;8);7;2)&"сек. "
 
The_Prist все нормально раскидывает, сумма диапазона D2:D10 считает, но как привести СУММУ к виду: ХХд. ХХ:ХХ:ХХ или ХХд. ХХч. ХХмин. ХХсек. Спасибо!
 
Добрый день V! Все нормально и понятно получильсь, но как посчитать СУММУ  диапазона D2:D10:  ХХд. ХХч. ХХмин. ХХсек. Спасибо!
 
А подумать немного и совместить мой вариант и вариант V? :-)

=СУММ(ЕСЛИ(ЕОШ(ПОИСК("д.";A2:A9));0;--ПСТР(A2:A9;1;ПОИСК("д. ";A2:A9)-1)))&"д. "&СУММ(--ПСТР(A2:A9;ДЛСТР(A2:A9)-7;2))&"ч. "&СУММ(--ПСТР(A2:A9;ДЛСТР(A2:A9)-4;2))&"мин. "&СУММ(--ПСТР(A2:A9;ДЛСТР(A2:A9)-1;2))&"сек. "

=СУММ(ЕСЛИ(ЕОШ(ПОИСК("д.";A2:A9));0;--ПСТР(A2:A9;1;ПОИСК("д. ";A2:A9)-1)))&"д. "&СУММ(--ПСТР(A2:A9;ДЛСТР(A2:A9)-7;2))&":"&СУММ(--ПСТР(A2:A9;ДЛСТР(A2:A9)-4;2))&":"&СУММ(--ПСТР(A2:A9;ДЛСТР(A2:A9)-1;2))
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
The_Prist прошу прощения! Я не указал, что в итоге необходимы преобразования и должно получится: 1 г. 25 д. 3 ч. 56 мин. 49 с. Если это возможно! Спасибо огромное!
Страницы: 1
Читают тему (гостей: 1)