Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Уникальные повторяющиеся значения
 
В приложенно файле - список номеров. Визуально видно, что они уникальны. Но если применить УФ по повторяющимся значениям, то Excel показывает их всех как повторяющиеся.
Насколько я понял, Excel третирует все эти номер как "3E+11", поэтому для Excel'я все они повторяются. Можно как-нибудь решить эту проблему? Спасибо.
There is no knowledge that is not power
 
"третирует" = "интерпретирует"?
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
Ага ;)
There is no knowledge that is not power
 
Цитата
Johny пишет:
как-нибудь решить эту проблему?
Вариант, далеко не лучший, - в начало - апостоф... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Судя по примеру начало у всех чисел одинаковое. Если так в оригинале, то можно проверять на уникальность не все число, а только посление n-знаков. Тогда в УФ можно использовать такую формулу:
=СУММПРОИЗВ(--(ПРАВСИМВ($A$1:$A$20;8)=ПРАВСИМВ(A1;8)))=1
 
Цитата
Z пишет:
Вариант, далеко не лучший, - в начало - апостоф...  ;)

Очень не лучший вариант.  :(  Я как раз от них и избавляюсь.  :)
Изменено: Johny - 14 Янв 2013 12:05:56
There is no knowledge that is not power
 
Избавляться через =ПСТР()не пробовали?!.  ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Цитата
sva пишет:
Судя по примеру начало у всех чисел одинаковое.

В том-то и дело, что числа могут быть любыми. Пока вносим эти коды, пока они начинаются одинаково, но всё может измениться... :(
There is no knowledge that is not power
 
Цитата
Z пишет:
Избавляться через =ПСТР()не пробовали?!. ;)

Немного не так поняли. Я имел ввиду, что мне как раз эти апострофы не нужны (что было предложено). А так - я от них другим способом избавился. ;)
There is no knowledge that is not power
 
Цитата
Johny пишет:
от них другим способом избавился. ;)
Вы уверены, что без последствий?!. Дайте пример из чего как что вы получаете, или нужно получить... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Тогда можно сравнивать частями
=СУММПРОИЗВ(--(ПРАВСИМВ($A$1:$A$21;10)=ПРАВСИМВ(A1;10));--(ЛЕВСИМВ($A$1:$A$21;11)=ЛЕВСИМВ(A1;11)))=1
 
Цитата
Z пишет:
Дайте пример из чего как что вы получаете, или нужно получить...
Было вот так: '032001801000111000032'
Применяю RegExp.Pattern = "\d+". Но дело-то, я очень надеюсь, ведь не в этом?  ;)

Цитата
sva пишет:
Тогда можно сравнивать частями
Как формула массива - работает, а в УФ - нет.  :(
Изменено: Johny - 14 Янв 2013 12:21:51
There is no knowledge that is not power
 
Странно, у меня работает.
 
Johny, неудобно вам напоминать (вы человек опытный), что пример - это пример в XL; возникший вопрос - это, скорее звено в цепи взаимосвязанных данных, действий и т.п.  А потому не мешает знать о предшествующих, настоящих и последующих этапах достижения поставленной цели... Извините... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Excel сам интерпретирует Ваши данные как числовые. А он не умеет различать числа больше 15 знаков, заменяя все, что дальше 15-го знакак нулями. Таким образом для Excel все Ваши эти "числа-текст" повторяющиеся.
Самый простой способ форматировать нормально именно повторения - только своей формулой. Что-то навроде этого:
=СЧЁТ(ЕСЛИ($A$1:$A$20=A1;))>1
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
The_Prist
Спасибо большое! А я бился со CЧЁТЕСЛИ. ;)
Проблема решена! Всем спасибо за помощь!
There is no knowledge that is not power
Страницы: 1
Читают тему (гостей: 1)
Наверх