Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1 2 След.
RSS
Поиск по части слова в ячейке
 
Добрый вечер!
У меня возник вопрос. Мне необходимо перетащить из базы стоимость детали по ячейке. Проблемы в том, что в таблице номенклатурный номер по которому необходимо вытаскивать данные представлен как 44А, а в Базе он состоит как РРК11 44А.
Вот и получается, что мне надо функция которая будет искать частичное точное совпадение. Воспользовалась формулой ВПР. Но она не срабатывает.
=IF(ISNA(VLOOKUP(TRIM(CLEAN("*"&A2&"*" ;) );$A$2:$B$10;2;0);"";(VLOOKUP(TRIM(CLEAN("*"&A2&"*" ;) );$A$2:$B$10;2;0)))
Помогите с формулой. Не тянет. А очень надо.
Большое спасибо!!!
 
ВПР с подставочными знаками работает при последнем параметре ИСТИНА (1) и диапазон поиска отсортирован по возрастанию.
Больше без примера сказать трудно чего.
 
Вот файл
 
Для вашего примера
Код
=ИНДЕКС($A$10:$B$12;ПОИСКПОЗ("*" &A2&"*";$A$10:$A$12;0);2)
Учимся сами и помогаем другим...
 
Спасибо!!!!!!!!!! Огромное. Уже 2 дня мучусь. А не подскажите как избавится от ошибки Н.д в данном примере?
 
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$10:$B$12;ПОИСКПОЗ("*" &A2&"*";$A$10:$A$12;0);2);"УПС!")
Изменено: ber$erk - 1 Апр 2013 21:38:38
Учимся сами и помогаем другим...
 
спасибо)))))))))))))))))))))))))))))))))))))
 
пожалуйста!  ;)
Учимся сами и помогаем другим...
 
А чем из этой формулы можно заменить функцию ЕСЛИОШИБ. А то она отсутствует.
 
Код
=ЕСЛИ(ЕОШИБКА(ИНДЕКС($A$10:$B$12;ПОИСКПОЗ("*" &A2&"*";$A$10:$A$12;0);2));"УПС!";ИНДЕКС($A$10:$B$12;ПОИСКПОЗ("*" &A2&"*";$A$10:$A$12;0);2))
Учимся сами и помогаем другим...
 
Вариант:
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ("*"&A2;A$10:A$12;));"УПС!";ВПР("*"&A2;A$10:B$12;2;))
Изменено: DV - 2 Апр 2013 15:01:09
 
LibO так LibO - в нем "подавитель" тоже работает...  ;)
"=IF(ISNA(INDEX($A$10:$B$12;MATCH("*" &A4&"*";$A$10:$A$12;0);2));"Упс!";INDEX($A$10:$B$12;MATCH("*" &A4&"*";$A$10:$A$12;0);2))"
А это - вариант "DальнеVосточный" -
=IF(ISNA(MATCH("*"&A4;A$10:A$12));"УПС!";VLOOKUP("*"&A4;A$10:B$12;2)) ...
Изменено: Z - 2 Апр 2013 15:08:25
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
не работает. Выводит УПС и все тут
 
Цитата
H5455 пишет: ... и все тут
А "пожалуйста" сказать, да подойти с ласкою?.. ;)
ps Проверено - XL-2010, Calc-4.0.1.2.
Со старо=новой смесью формул, надеюсь, разберетесь САМИ.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Спасибо, но ваш файл не открывается
 
Проверил - файл нормально открывается.
 
А теперь?
(файл от Z)
 
Спасибо, большое!
 
Цитата
H5455 пишет: Спасибо, но ваш файл не открывается
Если "НЕ", за что пасиба?!. ЧЕМ не открывается?!. Как, на что ругается?!. Сохраняли или сразу открывали?!. Как сохраняли?!.
ps Это для тех, кто пойдет вашими тропами... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
А если эти формулы в LibO не работают в основном  из-за того что я использую знак &, если без него то хоть и неправильно, но выдает числа, а с ним. либо пустота, либо ошибка 502
 
Цитата
H5455 пишет: ... А если...
Погадаем или Признаемся, что на деле ваш пример бесконечно далек от реальных данных?!.
В архиве - два файла.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
У меня не работают, даже те файлы что вы прикрепили. Если удалить пробел, а затем его опять поставить. формула перестает работать и пишет "УПС!"
 
Цитата
H5455 пишет: ... У меня не...
Учтем специфику ВПР в O_o&LibO - долой заморочки с "*" и "&"!.. ;)
Варьянт - =IF(ISNA(VLOOKUP(A2;$A$10:$B$12;2;0));"Упс!";VLOOKUP(A2;$A$10:$B$12;2;0))
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
К сожалению, :(  тот же УПС!
 
Цитата
H5455 пишет: ... К сожалению, :(тот же УПС!
Последний вариант только для опенов (и проверенный в них кстати), так что тараканы скорее где-то у вас...
А потому, наверное, переходите-ка на другие - ближние для вас по сути - планеты:
- http://community.i-rs.ru/index.php?PHPSESSID1=&board=5.0
- http://community.i-rs.ru/index.php/board,35.0.html
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Доброе утро!
Помогите пожалуйста с решением с подобной проблемы - есть 2 таблицы: в одной есть полный "Партийный номер" без количества, во второй - есть неполный "Партийный номер" с количеством. Как по частичному совпадению "Партийного номера" второй таблицы с "Партийным номером" первой, перенести количество в первую таблицу?
Заранее спасибо всем за помощь!!!
Образец прилагаю.
 
Для B2
=ВПР(ПСТР(A2;ПОИСК("-";A2;3)+1;ДЛСТР(A2)-ПОИСК("-";A2;3));A10:B14;2;ЛОЖЬ)
 
Рыбу раздали раньше... :(
Изменено: Z - 5 Июн 2013 09:34:26
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
anvg,
СПАСИБО!!! А подскажите еще пожалуйста, как убрать "НД" в данном случае?
 
Цитата
uigorek пишет: ... А подскажите...
Подсказки живут тута - http://www.planetaexcel.ru/techniques/1/...
Ваша - здеся -  http://www.planetaexcel.ru/techniques/2/106/, см. - Ошибки #Н/Д и их подавление... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
Страницы: 1 2 След.
Читают тему (гостей: 1)