Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
ВПР не подтягивает данные, в чем ошибка?
 
Уважаемые форумчане, прошу подсказать по следующей задаче : во вложенном файле в Листе 1 к стобцу Style description нужно подтянуть значения Subclass из Листа22, сопоставлять эти значения можно по столбцу Style кот. есть на двух этих листах, подтягиваю с помощью впр, но почему-то выходит ошибка N\A. Подскажите пож-та как ее исправить? Заранее спасибо.
 
=ВПР(A2;СЖПРОБЕЛЫ(Лист22!A$2:B$2684);2;0)

формула массива, вводится одновременным нажатием Ctrl, Shift и Enter
или избавтесь от пробелов на Лист22
 
У Вас 2 ошибки. 1 в данных на Лист 22 после кода еще 24 пробела, что для Экса совсем ни одно и тоже.
2 в формуле - надо закрепить границы таблицы.
=ВПР(Лист1!A2&"*";Лист22!$A$2:$B$2383;2;0)
 
Спасибо, подскажите пож-та, а как Вы определили, что в данных на Лист 22 после кода еще 24 пробела?
и зачем Вы еще написали A2&"*"
 
Посчитал передвигая клавишу :)  - есть функция определяющая количество знаков в ячейке=ДЛСТР(A9). Это подстановочные знаки звездочка "*" означает что значение равно значению в А2 и еще любому количеству знаков в ячейке.
 
столько нюансов - не знал - спасибо

Похожая тема
 
Более подробно про ВПР - Как найти значение в другой таблице или сила ВПР
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
Страницы: 1
Читают тему (гостей: 1)