Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как подсчитать количество уникальных значений в столбце по условию
 
Господа, помогите горемычной мне, приходится работать с большим количеством таблиц, где надо посчитать помимо количества договоров, количество тех с кем эти договоры заключены. вот пример! в ячейке которая выделена красным цветом нужна формула которая бы помогла посчитать количество уникальных значений в столбце "Наименование арендатора". использовать фильтры-не резон, так как это всего лишь часть таблички. Буду благодарна за помощь)
 
А что будет являться признаком заключения/НЕ заключения договора?
 
они все заключены(в том то и дело), но я хочу видеть что всего у меня заключено-24 договора, договоры с 21 предприятием. в красной ячейке нужна формула которая считает сколько предприятий заключили договоры, исключая повторы(не знаю доступно ли объяснила-я далеко не специалист)
 
Но ведь Вы пишете - "по условию". Так вот что это за условие? Или нужно просто количество уникальных?
 
сейчас сама поняла что нужно количество уникальных, приношу свои извинения...
 
Макрос.
 
спасибо огромное за помощь, сейчас попробуем.
 
=СУММПРОИЗВ(1/СЧЁТЕСЛИ(C5:C28;C5:C28))

Или формулой.
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
спасибо)))все, работает)с макросами у меня не опыта работы нет, с формулами привычнее)и тот и тот вариант считает
 
А зачем там опыт? - жмём на кнопочку - и всё )))
У Вас будут неверные данные в результате: в строках 24 и 26 данные похожи, но РАЗНЫЕ - в конце есть пробелы. В одном случае один, а во втором два. А для Excel это разные значения.
 
да я видела что там данные не одинаковые, спасибо) Я совсем не работала с макросами. Не буду объяснять в чем загвоздка-боюсь совсем уж глупой покажусь. Спасибо еще раз за помощь.
 
Цитата
Zaraza88 пишет: Не буду объяснять в чем загвоздка-боюсь совсем уж глупой покажусь.
Лучше - казаться, чем - быть...;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
:D   :D   :D   :D   :D
 
Вопрос такой по данной формуле
=СУММПРОИЗВ(1/СЧЁТЕСЛИ(A4:P16;A4:P16)
ни как не пойму математическую суть 1/. Разложил формулу на элементы а вот с этим действием для себя разобраться не могу.
Заранее спасибо за ответ.
Изменено: Василий - 14 Окт 2013 12:32:51
 
Смените отображаемое имя для начала...
 
я сменил, просто старые сообщения не обновляются с новым именем. Можно было просто объяснить пусть даже и ник не красивый.
Изменено: Василий - 14 Окт 2013 12:34:52
 
Здесь http://www.planetaexcel.ru/techniques/14/187/ подробно описано
Страницы: 1
Читают тему (гостей: 1)
Наверх