Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как в формуле писать слово, если оно само частично в кавычках?
 
Здравствуйте

Не могу понять, как в формуле писать слово, если оно само частично в кавычках?
Например:
Мясное ассорти "Казахстан" в формуле будет выглядеть, как
А2="Мясное ассорти "Казахстан""

или как-то по другому?

Благодарю за ответ.
 
Код
"Мясное ассорти ""Казахстан"""
 
Действительно, не любит вставок из двойных кавычек.
1. Вариант.
Возможность есть, например такая: "``УРА``" , т.е. вставка после кавычки (")  знака в англ. рег. (`) два раза!
PS Чтобы не тратить время, можно создать себе такой значок (``) и включить в список автозамены.

2. Вариант.
Создаете ячейку со значением "Колхоз", в свойствах ячейки (Формат ячеек...\Число\Текстовый ОК)
При необходимости вставить значение этой ячейки в формулу (которая в другой ячейке) - указываете ее имя, при этом в формуле кавычек не будет.
Изменено: Velrus - 11 Апр 2013 12:31:28
 
V, спасибо, работает.

Velrus, спасибо, не пробовал, потому что подошел вариант предложенный V.
Сам бы догадывался очень долго.
 
Подскажите, пожалуйста, а если в тексте только 1 кавычка?
Из системы грузится неполное наименование например ООО "Ромаш
Как в таком случае прописывать данный текст в формуле? если(А2="ООО "Ромаш""?
 
С файлом-примером.
Как Excel узнает, где окончание этого ООО?
 
Я для кавычек внутри текста использую «». (Alt+0171 и Alt+0187)
«Тот, кто несет фонарь, спотыкается чаще, чем тот, кто идет следом.»
Иоганн Пауль Фридрих Рихтер
 
Файл примера
 
=ЕСЛИ(ПОДСТАВИТЬ(A2;"""";)="ООО Ромашка"...
 
SergeyRudometov, а  на фига у вас ЕСЛИ? так, что не работает?
=СУММЕСЛИ($A$2:$A$19;A2;$C$2:$C$19)
 
Спасибо, Михаил, сработало
 
СИМВОЛ(34) :)  
Страницы: 1
Читают тему (гостей: 1)
Наверх