Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
формула, чтобы ячейка копировала формулу из другой ячейки, удаляя или заменяя в ней 1 символ
 
Есть ячейка С1, куда я вручную прописываю формулу,типа: "=A1*3+A2*2+A3*5" ,которая выдает значение в цифрах (13 400, например) мне нужно чтобы в B1 автоматически, при заполнении А1 проставлялась формула типа:="Сцепить(F1;" 3шт.";F2;" 2шт.";F3;" 5шт.")

то есть мне нужно скопировать формулу, заменив в ней в букву на другую букву и "*цифра" на "цифра шт."

возможно такое? без макросов желательно..
 
=ПОДСТАВИТЬ(A1;"цифра";"цифра шт.")
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
у меня в а1 числовое значение, не подходит. Сейчас пользуюсь СЦЕПИТЬ, но все руками приходится делать

вот прикрепил таблицу и картинку, нужно чтобы в С8 все автоматически проставлялось, когда я в С7 прописываю формулу вида: =C2*2+C3*5+C4*4
Изменено: Rafael - 22 Апр 2013 20:41:39
 
На мой взгляд, проще добавить ещё один столбец - количество.
И формула суммы будет более универсальной, и проблема со сцеплением решится достаточно просто
 
опять же руками вводить надо. А как максимально ускорить процесс этот. потому что перечислять много очень приходится.
А как сделать, чтобы я в одной ячейке ставил номер строки, в соседней сразу же выставлялся столбец, соответствующий номеру строки?   я ставлю "2"  а рядом в ячейки "=А2"
Изменено: Rafael - 20 Апр 2013 17:27:21
 
Может быть так?
 
нет
я руками вводить не хочу 10 раз. и мне нужно именно в одной ячейке прописать формулу вида: =C2*2+C3*5+C4*4
и чтоб пока я ее пишу, мне автоматом выдовал в другой ОДНОЙ ячейке:
=СЦЕПИТЬ(A2;" ";B2;" ";"множитель 2шт.";СИМВОЛ(10);A3;" ";B3;" ";"множитель 5шт.";СИМВОЛ(10)A4;" ";B4;" ";"множитель 4шт.";СИМВОЛ(10);


в теме моей же соседней подсказали индексом воспользоваться. вот это уже ближе к реальности... осталось сообразить как все это в кучу собрать.

на данный момент мне приходится прописывать в разных ячейках строку и количество товара.
=ИНДЕКС(A:A;J1)&ИНДЕКС(B:B;J1)&K1&L1
где
J1 строка товара
К1 - количество
L1 - шт.

нужно как то заставить индекс находить в формуле нужный символ. то есть вместо нужно что то умное написать..

может писать C2*2+C3*5+C4*4 без знака равенства? тогда можно буде выбирать нужные символы, но тода как формулу потом сделать.
Изменено: Rafael - 22 Апр 2013 20:42:03
Страницы: 1
Читают тему (гостей: 1)