Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Добавить в формулу "если текст в D2 начинается на "ч" ".
 
Есть формула, подставляющая в ячейку значение из V1, если в C2 не пусто.
Помогите, пожалуйста, добавить "если текст в D2 начинается на "ч" ".

=ЕСЛИ($C2="";"";(ЕСЛИ($D2=….;"";$V$1)))
 
=ЕСЛИ($C2="";"";(ЕСЛИ($D2="ч";"";$V$1)))
=ЕСЛИ($C2="";"";(ЕСЛИ($D2="ч";$V$1;"")))
Что-то Вопрос и Пример расходятся.
Одно из двух Чоловіки або Жінки.
(Если правильно написал)
 
Спасибо. Второй вариант
=ЕСЛИ($C2="";"";(ЕСЛИ($D2="ч";$V$1;"" ;) ))
предпочтительней.
Но нужно, не =ч, а начинается с ч. Дело в том, что будут и "Чоловіки" и "чолов" и "чол" и только "Ч"...
В примере "ж" для пробы. А по украински Вы верно написали.
Изменено: iam1968 - 22 Апр 2013 18:32:55
 
=ЕСЛИ($C2="";"";(ЕСЛИ(ЛЕВСИМВ($D2)="ч";$V$1;"")))
Так?
 
Да, то, что надо. Спасибо большое.
 
А как правильно будет формула, если необходимо чтобы учитывались ячейки, которые содержат определенный текст?
Например есть массив ячеек с похожим текстом:
отправлено 22/01/15
отправлен
отправила
пусто
отправлено в марте

Логично что везде присутствует "отправ" и его то и нужно подсчитать
Я ввожу =ЕСЛИ(A14="отправ","да","нет")
Но получается что ячейки не обсчитываются в таком виде
   
 
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("отправ*";A1));"да";"нет")
Excel 2013
Страницы: 1
Читают тему (гостей: 1)