Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формула МЕСЯЦ, Возврат "1", если аргуметом является пустая ячейка
 
Добрый день!
 При пользовании функцией МЕСЯЦ для массива, результат работы формулы, где аргументом является пустая ячейка выводится “1”. Как будто везде где пустая ячейка это какая-то январская дата.
Возможно ли это как то исправить ??? Можно ли сделать так что б пустые ячейки вообще не обрабатывались формулой ???
 Дело том что что мне нужно будет делать расчет с формулой СУММАЕСЛИ, для того столбца где выводятся месяца, и если эта единица так и будет выводиться, то по январю у меня будет неверные данные...
Спасибо!
 
приложите пример с вашими данными и необходимым расчетом в виде файла xls
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
Код
=ЕСЛИ(A1="";"";МЕСЯЦ(A1))
, где А1 - ссылка на ячейку с датой.
Изменено: SprObj - 28 Апр 2013 15:44:37
 
Для Excel 0(или пусто) в переводе на дату это 00.01.1900. Т.е. январь  :)  
А функция МЕСЯЦ автоматом переводит любое значение в дату, если его в неё можно преобразовать.
Так что тут надо либо использовать совет SprObj, либо выложить файл с функцией и показать наглядно, что хотите сделать.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
Страницы: 1
Читают тему (гостей: 1)