Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Заполнить таблицу по данным другой таблицы
 
Добрый день!

По данным таблицы на вкладке 2, необходимо заполнить должность сотрудников в таблице на вкладке 1.
Как это можно сделать при помощи функции ВПР?
 
При помощи ВПР ни как.
формула массива
Код
=ИНДЕКС('2'!$A$1:$C$1;МАКС(ЕЧИСЛО(ПОИСК(B2;'2'!$A$2:$C$4))*СТОЛБЕЦ($A1:$C1)))
 
Почти то же, что у Михаила:

=ИНДЕКС('2'!$A$1:$C$1;;МАКС(('2'!$A$2:$C$4=B2)*{1;2;3}))
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Когда я протягиваю первую формулу, то все дворники получаются, когда вторую - первые три ячейки определяет неправильно, а остальные #ЗНАЧ. Я что-то не так сделала?
 
Формула массива
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
теперь поняла, но забыла сочетания клавиш, которые нужно нажать. Подскажите.
 
спасибо большое, нашла в ссылке Формула массива
 
Ольга, а в статье разьве не написано про клавиши? Или читать лень совсем? Может будем уважать отвечающих?
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Спасибо.
Страницы: 1
Читают тему (гостей: 1)
Наверх