Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Десятичные знаки
 
Добрый день.
Подскажите, пожалуйста.
Почему после применения функции СУММЕСЛИ полученный результат в ячейке выглядит как 0,0001, а если его скопировать и вставить в любую другую ячейку как значение, то число выглядит уже как 0,000099999999999989. Как это победить?
 
ОКРУГЛ и иже с ними.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Цитата
АКС пишет:
Как это победить?
а что именно нужно "победить"?
 
Дело в том, что к этому значению в дальнейшем применяется еще раз функция СУММЕСЛИ, где критерием является «=0,0001». Хотя значение отображается как 0,0001, но по факту является 0,000099999999999989 то функция ее и не суммирует.
 
Цитата
АКС пишет: ... Дело в том, что...
Для предметного разговора - файл в студию, в реальной структуре и форматаx и пояснениями.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Проблема в столбце «E». Функция СУММЕСЛИ отказывается считать.
 
Насколько вник (вернее ничего не понял - что, зачем, почему?) - "=ОКРУГЛ(ЕСЛИ(A2>A3;A3-A2;A3-A2);4)"...  :(
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
...или в параметрах задать "точность как на экране"
 
Цитата
Z пишет:
Насколько вник (вернее ничего не понял - что, зачем, почему?) - "=ОКРУГЛ(ЕСЛИ(A2>A3;A3-A2;A3-A2);4)"...  :(
Все заработало!!! Огромное человеческое спасибо!!!
 
Может так.
Страницы: 1
Читают тему (гостей: 1)
Наверх