Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Нестандартная нумерация в списке ФИО,
 
Есть список ФИО с D3 по D22. Помогите создать формулу которая нумерует по порядку ФИО в столбце D (с D3 по D22)
 
Baur69, и чем она не стандартна? Формула не может изменять значение в той же ячейке D3 по D22, а вот в соседних столбцах от простой
Код
=СЧЁТЗ($D$3:D3) до простенькой комбинации для исключения повторов фамилий =ЕСЛИ(СЧЁТЕСЛИ($D$2:D2;D3);"";МАКС($C$2:C2)+1)
 
http://planetaexcel.ru/techniques/2/80/  ;)
 
В отличии от стандартной нумерации, данная отличается тем, что необходима нумерация в самой ячейке, а там список имен достаточно приличный.
 
покажите, что хотите получить в результате.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Формула не поможет.
Макрос:

Код
Sub tt()
    Dim cc As Range, i&
    For Each cc In [d3].CurrentRegion.Cells
        i = i + 1: cc = i & " " & cc
    Next
End Sub
 
Цитата
Baur69 пишет:
необходима нумерация в самой ячейке
Вам уже ответили, что формула в самой ячейке не умеет.
 
Цитата
The_Prist пишет:
покажите, что хотите получить в результате.

файл прилагается.
 
=СТРОКА(A1)&". "&D3

Далее "убиваем" формулы: Как удалить в ячейке формулу, оставив значения?
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
=СТРОКА()-2&". "&"BOUGHABA ACHRAF"
Изменено: Niff-Nif - 5 Июн 2013 13:43:32
 
И так для каждой ячейки?  :)  ФИО-то разные. проще сразу в ячейку заносить тогда...
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Baur69, С таким подходом Вам еще несколько раз помогут, а потом :?:  Делаем нумерацию в одном столбце, в другом сцепляем данные с номерами и фамилиями =B3 & ". " & D3? потом копируем и через спец вставку вставляем в нужное место. Делов на минуту, а Вы ждете пока за Вас все сделают.
 
Цитата
The_Prist пишет: И так для каждой ячейки?
ХРЮ, так ведь человек хочет помучаться...  ;)
 
Цитата
Niff-Nif пишет:
так ведь человек хочет помучаться
Niff-Nif, человек хочет получить помощь.
 
Цитата
The_Prist пишет: =СТРОКА(A1)&". "&D3
Спасибо большое! За волшебную формулу !!!
 
Доброе утро! Столкнулся с проблемой, при работе с ВПР.
The_Prist, можно ту же формулу которую Вы создали, создать так, чтобы она убирала нумерацию?
 
а не проще старый текст снова скопировать?
в соседней строке
Код
=ЗАМЕНИТЬ(G3;1;НАЙТИ(" ";G3;1);"")

потом
Цитата
Далее "убиваем" формулы.[/url]
не пинайте очень сильно,я пытаюсь научиться
Страницы: 1
Читают тему (гостей: 1)