Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Перенос данных из одной ячейки в другую с заменой символов
 
Добрый вечер, форумчане!
Прошу помощи.
Мы получаем результаты ЕГЭ в таком виде, что провести анализ результатов очень затруднительно. Где-то стоят плюсики, где-то минусики, а где-то баллы от 1 до 14. Для маленьких массивов можно сделать это по принципу "закат солнца вручную", но часто проскакивают ошибки.
Файлик с примером на Листах 1 и 2 прикрепляю.
Очень хотелось бы все преобразования сделать с помощью стандартных формул...
 
VladKomp, смотрел Ваш файл, постановка задачи не совпадает с примером :o
А если пользовательская функция на примере Вашего макроса?
 
Стар стал - плох стал... Спасибо.
Прикрепляю нужный.
 
Лист 1:
=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(B3;"+";"1 ");"-";"0 "))
Лист 2:
Ctrl+H
Найти (*) Заменить на Пробел
с Листом 1 можно поступить также
Изменено: Nic70y - 7 Июн 2013 00:03:20
 
Спасибо, Nic70y. Формула работает хорошо, только проблема в том, что после разноски символов по ячейкам не определяется сумма баллов из-за того, что в ячейках появляются пробелы - я так думаю. Удаляю пробелы из ячеек - исчезает разбиение. Замкнутый круг.
Пояснее проблему видно в файле.
 
=--СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(" "&$C4;" ";ПОВТОР(" ";99));СТОЛБЕЦ(A1)*99;99))
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Шик! Самый высший класс! Впервые встречаюсь с таким использованием символа!
Спасибо!
К формуле я еще добавил функцию ЕСЛИ и все стало чудненько.
 
VladKomp, еще можно было к значению функции прибавить ноль или умножить его на 1. Эксель при этом проведет преобразование типа данных.
 
Зачем такие сложности (см. файл)
или универсальная с D4
=ЕСЛИОШИБКА(--ЕСЛИ(ЕЧИСЛО(ПОИСК("(";$B4));ПСТР($B4;СТОЛБЕЦ(A1)*4-3;1);ЕСЛИ(ПСТР($B4;СТОЛБЕЦ(A1);1)="+";1;ЕСЛИ(ПСТР($B4;СТОЛБЕЦ(A1);1)="-";0;ПСТР($B4;СТОЛБЕЦ(A1);1))));"")
Изменено: Nic70y - 8 Июн 2013 01:04:40
Страницы: 1
Читают тему (гостей: 1)
Наверх