Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Форумы "Планета Excel" » Вопросы по Microsoft Excel
Страницы: 1
RSS
Название файла в формуле
 
Здравствуйте,

Есть файл-шаблон, который обращается к другим файлам. Названия файла-шаблона и название файлов к которым он обращается каждый день изменяются. Но путь (кроме самого названия файла) остается прежним.  Можно ли написать формулы так, чтобы в определенной ячейке можно было вписывать название файла к которому надо обращаться, а формулы бы менялись самостоятельно?
Например,
Формула: =ЕСЛИОШИБКА(ВПР(A101;'C:\Dropbox\2013\ППП\[НАЗВАНИЕ ФАЙЛА]Лист1'!$A:$F;6;ЛОЖЬ);"!!!")
Название файла, которое надо вставить вместо фразы "НАЗВАНИЕ ФАЙЛА" - 01.xlsx

Заранее благодарю за ответ
 
попробуйте функцию ДВССЫЛ
Учимся сами и помогаем другим...
 
Попробовал вписать ДВССЫЛ в квадратные скобки. Не получилось. Может быть вы можете объяснить подробнее?
 
Код
=ЕСЛИОШИБКА(ВПР(A101;ДВССЫЛ("'C:\Dropbox\2013\ППП\["& A1 &"]Лист'!$A:$F");6;ЛОЖЬ);"!!!")

в А1 имя файла
Изменено: ber$erk - 10 Июл 2013 15:05:47
Учимся сами и помогаем другим...
 
Я правильно вас понял, что мне надо в ячейке А1 указывать название файла к которому будет идти обращение?
 
ну да - Ваше "01.xlsx"
Учимся сами и помогаем другим...
 
ber$erk, Ваша формула не будет работать. Полный путь к книге указывается в одном случае - если книга закрыта. А ДВССЫЛ не умеет работать с закрытыми книгами.
Так что ответ один - только макросами.
Как вариант можно воспользоваться функцией Get_Value_From_Close_Book из этой статьи: Как получить данные из закрытой книги?
Как использовать написано там же. Правда, для получения массива ячеек для ВПР надо будет явно что-то изменить...А еще лучше свою ВПР написать, которая будет брать данные из закрытой книги.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
ber$erk, ваша формула не работает(((
The_Prist, жаль.
Страницы: 1
Читают тему (гостей: 1)