Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Не работает поиск символов, содержащих "~"
 
Добрый день!
При поиске значений, содержащих символ "приблизительно равно" функцией ВПР, выдается сообщение об ошибке.
Пример:

A1 содержит xxx~zzz
B1 выполняет поиск значения A1 в ячейке A1
Код
=ВПР(A1;A1;1;0)

Результат: #Н/Д

Заранее благодарю за помощь.
Изменено: qawer - 27 Июл 2013 16:33:52
 
Если разговор именно о поиске (Ctrl+F), то ищите ~~ (две тильды).
 
Речь о функции ВПР: посмотрите пример, пожалуйста.
 
qawer, вот скажите мне - с какой целью Вы меня цитируете?
 
Еще не привык к данному движку - сегодня первый день.
 
См. файл.
 
Т.е. возможно выполнить поиск только до тильды, используя приблизительные значения?
 
Честно говоря, я не понял - ЧТО Вы хотите искать. Судя по названию темы - тильду, в примере совсем другое...
 
А вот это:
Цитата
qawer пишет:
B1 выполняет поиск значения A1 в ячейке A1
вообще за пределами моего понимания))
 
Не известно какие еще данные у Вас могут быть :) см. файл:
 
Цитата
Юрий М пишет: Честно говоря, я не понял - ЧТО Вы хотите искать.
Вы использовали "1" в интервальном просмотре, поэтому в вашем примере поиск приблизительных значений.
Мне нужен точный поиск.
Заменил в поиске одну тильду на две - ошибка пропала.
 
Вы на мой вопрос так и не ответили (ЧТО искать), да мне и не нужно. А про двойную тильду я раньше писал.
 
Цитата
qawer пишет:
Еще не привык к данному движку - сегодня первый день.
А что тут привыкать? Если не хотите цитировать - не нажимайте ссылку с ТАКОЙ надписью.
 
Цитата
Юрий М пишет: ...про двойную тильду я раньше писал.
Мне нужно найти текстовое значение с тильдой с точным соответствием.
 
=ВПР(ПОДСТАВИТЬ(A1;"~";"~~");A1;1;0)
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Nic70y, Юрий М и The_Prist, большое спасибо, очень помогли!
Проблема решена.
Страницы: 1
Читают тему (гостей: 1)
Наверх