Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Проверка по диапазону с подстановкой значения
 
Всем привет!

Есть диапазон "продукты" (столбец Е), по которому должен проверяться "список" (столбец А).
Если в ячейках "списка" есть вхождение из "продуктов", то в соседнюю ячейку "проверки" (столбец B) вписать имя диапазона, ну или просто слово "продукты". Если вхождение не подтверждается, оставить ячейку пустой.

Моя формула некорректно работает:
Код
=ЕСЛИ(И(ЕОШ(НАЙТИ(продукты;A2)));"продукты";)

Пожалуйста, помогите исправить.
Изменено: kesha - 27 Июл 2013 16:35:20
 
=ЕСЛИ(НЕ(ЕОШИБКА(НАЙТИ(продукты;A3)));"продукты" ;)
Вместо И нужно использовать НЕ.
 
У меня опять некорректный результат:
Код
список   проверка
яблочный стейк   продукты
гороховый сок   ЛОЖЬ
сливовый суп   ЛОЖЬ
банановый борщ   продукты
хреновый сироп   ЛОЖЬ

и как избавиться ото "лжи"? )
 
Формула массива ("трехпальцевый" ввод):
{=ЕСЛИ(И(ЕОШ(НАЙТИ(продукты;A2)));;"продукты")}
{=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК(продукты;A2)));$E$1;"хреновые продукты")}
 
vikttur, спасибо, но опять таки, некорректно.

Решение отсюда:
Код
=ЕСЛИ(СУММПРОИЗВ(-ЕЧИСЛО(ПОИСК(продукты;A2)));"Продукты";"")
 
Вы о формуле массива прочитали?
 
Как вариант.
Страницы: 1
Читают тему (гостей: 1)
Наверх