Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Присвоение нового значения ячейке
 
Уважаемые, помогите, пожалуйста!
Есть столбец со значениями: 09041; 2001; 2002; 2003;...; 2015; 11009; 2001; 2002....
Нужно чтобы в соседнем столбце ставились значения первого не начинающегося на 2 значения. То есть в первых 16-ти строках 09041, затем в следующих 16-ти - 11009, и т. Д.
Проблема еще и в том, что значений на 2 может быть разное количество...
И да, формула должна быть протягиваема.
Вот такая вот задачка. Буду очень признательна за помощь!
 
а чем не подходит сортировка по возрастанию?
не пинайте очень сильно,я пытаюсь научиться
 
Не подходит. Это допиливание выгрузки из 1с. И потом мне не надо сортировать.
Я наверно плохо описала задачу.
Значения не на два - это верхний признак иерархического списка (ну как, например 1). Значения на 2 - это вторая ступень. (Продолжая пример - 1.1). Потом идет следующее верхнее значение (2). Потом (2.1 и т. Д.).
Ну вот как-то так.
Изменено: Ulala - 31 Июл 2013 08:50:14
 
Я вот тут пример сделала. Мне надо, чтобы автоматически заполнялся столбец B.

Помогите, пожалуйста!
 
В ячейку D2:
=ЕСЛИ(ПСТР(A2;1;1)<>"2";A2;D1)

Кстати, "Общех" тоже не начинается на 2. Поэтому попадет в подсписок.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
The_Prist, не, не так.. ))
так я уже делала. Счастье заканчивается на строке со значением <...>.. ((((
Изменено: Ulala - 31 Июл 2013 12:13:11
 
=ЕСЛИ(ЕЧИСЛО(-ЛЕВСИМВ(A2));ЕСЛИ(--ЛЕВСИМВ(A2)<>2;A2;B1);B1)
Если нужно, добавьте проверку на отсутствие в первой ячейке диапазона "правильного" значения.
 
vikttur, Вы мой спаситель! Спасибо огромное! благодаря Вам спасено пара жизней как минимум - нас не порвали на британский флаг ))))

А расскажите мне, пожалуйста, что дает знак "-" перед формулой? или "--"?
 
"-" - минус, как и везде. с его помощью преобразуется текст в число. То же (и много другого) может и бинарное отрицание (интересно? задайте словосочетание в поисковике).
Страницы: 1
Читают тему (гостей: 1)
Наверх