Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование на основе нескольких критериев
 
Здравствуйте!

У меня такой вопрос:
В листе 2 идет список клиентов
в Листе 1 нужно узнать, сколько именно этот клиент купил позиции ИП-52
ИП-52 как пример, они постоянно будут меняться
Можно ли решить задачу не меняя формы, которая выгружается с 1С (т.к. позиций товара 500, каждый раз приводить форму в соответствие просто нереально)

Заранее благодарю!
 
=СЧЁТЕСЛИМН Вам поможет
Изменено: Sanja - 5 Авг 2013 18:46:25
Согласие есть продукт при полном непротивлении сторон.
 
Тут прежде чем СЧЕТЕСЛИМН и СУММЕСЛИМН(я думаю она больше должна подойти) применять, надо данные привести к виду, который эта СУММЕСЛИМН сможет обработать. По сути, если в каждом товаре есть добавка в виде скобок, то можно в С2 записать такую формулу:
=ЕСЛИ(ЕОШ(ПОИСК("(";A2));A2;C1)
и протянуть.
А дальше уже использовать СУММЕСЛИМН или СУММПРОИЗВ.

Если же не везде скобки, то...Даже не уверен, что можно решить без списка всех товаров.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Цитата
The_Prist пишет:
Тут прежде чем СЧЕТЕСЛИМН и СУММЕСЛИМН(я думаю она больше должна подойти) применять, надо данные привести к виду, который эта СУММЕСЛИМН сможет обработать. По сути, если в каждом товаре есть добавка в виде скобок, то можно в С2 записать такую формулу:
=ЕСЛИ(ЕОШ(ПОИСК("(";A2));A2;C1)
и протянуть.
А дальше уже использовать СУММЕСЛИМН или  СУММПРОИЗВ .

Если же не везде скобки, то...Даже не уверен, что можно решить без списка всех товаров.

Спасибо большое!! Хотя бы так но проблема решена! =)
Страницы: 1
Читают тему (гостей: 1)
Наверх