Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Исправить формулу СУММЕСЛИ, неверно считает из-за *
 
Доброго дня, планетяне.
Использую формулу СУММЕСЛИ, у товара в наименовании присутствует знак *, формула воспринимает его как служебный (любое количество символов), и из-за этого получаются неверные вычисления. Помогите, как исправить ситуацию? Способ с заменой "*" на другой символ не предлагать. Файл с примером во вложении.
Изменено: Chyma - 9 Авг 2013 11:11:25
 
Цитата
Использую формулу
А почему не сводная?!. ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
=СУММПРОИЗВ((ПОДСТАВИТЬ(A2;"*";"x")=ПОДСТАВИТЬ('Исходные данные'!$A$2:$A$5;"*";"x"))*'Исходные данные'!$B$2:$B$5)
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Используйте
Код
=СУММПРОИЗВ(('Исходные данные'!A2:A5=A2)*'Исходные данные'!B2:B5)
 
Спасибо.
 
Код
=СУММЕСЛИ('Исходные данные'!A:A;ПОДСТАВИТЬ(A2;"*";"~*");'Исходные данные'!B:B)
Страницы: 1
Читают тему (гостей: 1)
Наверх