Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
ВПР - выбрать самое минимальное, Выбрать наименьшее значение
 
Здравствуйте )). Есть Вася и Петя, предлагают купить яблоки и бананы. Как мне определить у кого наименьшая цена продукта и вставить цену в нужную ячейку?  :)
 
Формула массива
Код
=МИН(ЕСЛИ(L4=C$4:C$7;ЕСЛИ(D$4:I$7<>0;D$4:I$7)))
 
наверное я что-то сделал не так? не получается
 
формула массива, вводится одновременным нажатием Ctrl, Shift и Enter
 
а-а-аа, не увидел, что это массив))) Спасибо огромное!!!
 
Nic70y: формула массива
Николай Венгеров: не увидел, что это массив
))
 
=МИН(ЕСЛИОШИБКА(ЕСЛИ($C$4:$C$7=L4;1;"")*$D$4:$I$7;""))
 
не массивная:
=МИН(СМЕЩ($D$4:$I$7;ПОИСКПОЗ($L4;$C$4:$C$7;0)-1;0;1))

Правда, нигде не увидел в условиях задачи исключения нулевых значений. Поэтому не пытался обрабатывать.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
если надо вытянуть поставщика
=ИНДЕКС($D$3:$I$3;1;ПОИСКПОЗ(M4;СМЕЩ($C$3;ПОИСКПОЗ(L4;$C$4:$C$7;0);1;1;СЧЁТЗ($D$3:$I$3));0))
Страницы: 1
Читают тему (гостей: 1)