Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выборка данных по нескольким условиям
 
Здравствуйте! Прошу помочь: Необходимо из одного листа таблицы выбрать данные (тоннаж, выручка, маржа), соответствующие значениям в 2-х столбцах: ЦФО и Бренд и подставить их в другой лист таблицы в ячейку, соответствующую этим же двум значениям.
 
формула мвссива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$2:$E$30;ПОИСКПОЗ(1;((Лист2!$A$2:$A$30=$A2)*(Лист2!$B$2:$B$30=$B2));0);СТОЛБЕЦ());"-")
Изменено: Ivan.kh - 15 авг 2013 14:34:17
 
Отвечали мне вчера.
Подобная весчь. Вам сюда
 
Спасибо огромное за помощь!
 
А вот на живом файле почему-то не получается ...
 
И что Вы предлагаете?  :D
Я сам - дурнее всякого примера! ...
 
Не знаю, не могу понять в чем ошибка... Везде ЗНАЧ...
 
А Вы точно формулу комбинацией из трех пальцев вводили?
Я сам - дурнее всякого примера! ...
 
Не смешно...
 
Может попробовать с помощью СУММПРОИЗВ без массивных формул?
 
Цитата
Lenus'ka:
Не смешно...
Что не смешно? Формула массива вводится тремя клавишами ctrl+shift+enter. А Вы что подумали?  :evil:
Изменено: KuklP - 15 авг 2013 17:04:09
Я сам - дурнее всякого примера! ...
 
Цитата
Lenus'ka: Не смешно...
а что смешного??? Я же написал, формула массива, а они вводятся сочетанием клавиш Ctrl+Shift+Enter
 
Я так и вводила... Вот и пишу что не смешно...
 
Lenus'ka, вариант без формул массива смотрели?
 
Вот смотрю как раз. 5 сек.
 
Алексей К, Она данные суммирует, а мне нужно просто подстановка значений с листа 2
 
Ну по идеи если сочетания ЦФО и БРЕНД не повторяются и нужно подставлять числа, то СУММПРОИЗВ, или СУММЕСЛИМН как раз подойдут
Изменено: Ivan.kh - 15 авг 2013 17:24:51
 
Где неверно? покажите. Да, действительно, формула находит все совпадения и суммирует. А как Вы хотите, чтобы было? Если у Вас несколько строк с одинаковыми данными в 1 и 2 столбцах, что должно подставляться?
 
Должны подставляться значения по каждой позиции. Не может встретиться одного и того же БРЕНДА и одного и того же ЦФО.
 
Пример, где не получается ввести массивную ф-цию выложите??
 
Тогда что не так в предложенном варианте? Как сказал Ivan.kh, можно сделать еще с помощью СУММЕСЛИМН. Результат будет аналогичным.
З.Ы. Кстати в моем файле Вашего примера массивная формула от ivan.kh работает
Изменено: Алексей К - 15 авг 2013 17:30:18
 
Выложила бы, Файл очень большой.
Изменено: Lenus'ka - 15 авг 2013 17:29:14
 
Вариант с доп. столбцом без массива

З.Ы.
ЦФО БРЕНД   тонны     выручка маржа
Москва Титан     6,89    65 084,77 12 571,00
Москва Титан     6,53    62 754,27 12 386,22
Что в этом случ. должно вывести???
 
В этом случае да, но по формуле Алексей К везде всё просуммировалось...
 
Lenus'ka, что да??
 
Если две одинаковых позиции по бренду и цфо - то да, долждна вывестись сумма.
 
ну так тогда СУММПРОИЗВ, или СУММЕСЛИМН
 
Здравствуйте! Нужна ваша помощь!

На листе номер 3 есть данные согласно заданным условиям(столбец B,J,K), мне необходимо если j>0 и период соответствует заданному условию B, то столбец k необходимо разложить в таком порядке:

условие 14-00 понедельник (все понедельники месяца)

420
457
и т.д.
это необходимо для поиска среднего по каждому получасу.

спасибо!
 
Не понятно, что нужно сделать!
Страницы: 1
Читают тему (гостей: 1)
Наверх