Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
#ЗНАЧ! при вычислениях, как избавиться?
 
есть ячейки а1 + а2 + а3 = а4
если они пустые или с "нулем" - все хорошо, при суммировании получаем а4 = 0. но если в одной из них прописана какая то формула, которая выдает "ничего" (в моем случае - впр) то получаю злополучный #ЗНАЧ! в результате. как избавиться? неужели только ручным проставлением нуля в исходной таблице и всякими там еошибками???
 
=сумм(а1:а3)
 
как все элементарно...

спасибо большое :)
 
так.. с этим то просто, а как быть например с подобным случаем деления?

когда пустоту делим на пустоту например?
 
Цитата
как избавиться?
Нужно лечить не симптомы. Нужно от болезни избавляться.
Цитата
когда пустоту делим на пустоту например?
=ЕСЛИ(B1="";"";A1/B1) или почти то же:
=ЕСЛИ(B1;A1/B1;)
 
а что нужно получить при делении на пустоты?
...есть такая функция ЕСЛИ называется, применяем ее. а в версиях с 2007 есть ЕСЛИОШИБКА

Вить, =ЕСЛИ(B1;A1/B1;) не всегда применима... "пустоты" то ведь тоже разные бывают....
Изменено: Михаил С. - 25 Авг 2013 23:18:51
 
Я, конечно, сейчас напишу гадость, но: обычно, если предполагается результат вычисления формулы применять в мат.операциях, то вместо ""(строки нулевой длины) прописывают нуль. Это избавляет от мно-о-огих проблем...
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Цитата
...есть такая функция ЕСЛИ называется, применяем ее. а в версиях с 2007 есть ЕСЛИОШИБКА

еошибка и еслиошибка - это ж одно и тоже, я так поняла?
 
Цитата
одно и тоже
нет:
 
то есть, если(еошибка(а1/а2)=истина;0;а1/а2) = еслиошибка(а1/а2;0)   ????
 
Цитата
=истина
вот это в формуле лишнее, т.к.
Цитата
еошибка(а1/а2)
и так выдаст значение истина или ложь. а так все верно.
 
ага, поняла, спасибо!!!)) :)
 
еще один нюанс еошибка используется в ранних версиях, а еслиошибка только в версиях выше 2007 - соответственно в версиях ниже 2007 не читается.
Страницы: 1
Читают тему (гостей: 1)