Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
подсчет заполненных ячеек
 
Уважаемы специалисты,
прошу подсказать, как мне посчитать кол-во заполненных ячеек в строке с не повторяющимися значениями, но не все подряд а через одну.
см файл - в моем примере надо поставить формулу в столбец В, так что бы она считала сколько заполнено ячеек в столбцах С и Е (и т.д)
моя задача - надо определить сколько мест (коробок) находится в паллете.
очень надеюсь на вашу помощь!

Не нужно писать через строку [МОДЕРАТОР]
Изменено: vvoollggaa - 31 Авг 2013 10:07:29
 
вариант
 
Только для двух:
=ВЫБОР((C2>0)+(E2>0)+1;;1;(C2<>E2)+1)
Для многих (формула массива, ввод Ctrl+Shift+Enter):
=СЧЁТ(1/ЧАСТОТА(ЕСЛИ($C$1:$H$1=$C$1;ЕСЛИ(C2:H2>0;C2:H2));{1;2;3;4;5;6;7;8;9}))
 
V - ОГРОМНОЕ спасибо! это, конечно, оч круто! подстроил для свей таблички - всё работает!
vikttur - Вам тоже большое спасибо, только у меня более 2х (20 с лишним)
 
Добавил формулу.
 
СПАСИБО!
 
Здравствуйте, Вроде задача кажется не очень сложной,но не получается. Задача посчитать количество заполненных ячеек, которые находятся в заданном диапазоне дат. Буду очень признателен!
 
L3:L22 <>"", не?
 
Влад, попробовал подставить, не очень понял и не работает
 
такая вариация
Код
=СУММПРОИЗВ(($I$3:$I$22>=$F$1)*($I$3:$I$22<=$F$2)*($L$3:$L$22<>""))
Лень двигатель прогресса, доказано!!!
 
Сергей, респект и уважения вам:)!!! Долго я сидел на этой казалось бы несложной задачей!
 
ну и такой вариант
Код
=СЧЁТЕСЛИМН($I$3:$I$22;">="&$F$1;I3:I22;"<="&$F$2;L3:L22;"*?")
Лень двигатель прогресса, доказано!!!
 
Добрый день, подскажите пожалуйста, как можно посчитать количество ячеек с условиями с "закрытого" исходного файла. Когда считаю формулой СЧЕТЕСЛИМН все считается пока исходный файл открыт, как только закрываю файл, выдает ошибку.
Страницы: 1
Читают тему (гостей: 1)