Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формула для работы с текстом
 
Доброго дня!
Долго мучался, но нужной формулы так и не подобрал... Помогите пожалуйста.
Задача такая: на листе 1 в столбце А находится производитель+название туалетной воды. На листе 2 в столбце А только производитель, в столбце В страна производства.
Нужно на листе 1 в столбце В напротив воды поставить страну производства.
 
Функция ВПР()
 
не срабатывает
Изменено: Олег - 8 Сен 2013 22:25:07
 
Как найти значение в другой таблице или сила ВПР
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Цитата
не срабатывает
Не верю. Покажите.
 
прикрепил в предыдущем ответе файл
 
Изучайте
http://www.planetaexcel.ru/forum/index.php?PAGE_NAME=read&FID=2&TID=9
 
RAN по изучал, но в макросах я не силён ...
по вашей ссылке скачал файл и вставил свою информацию, и макрос обработал её не корректно
 
Если честно, у Вас там полная каша. В одной таблице значения содержат как меньше символов, чем в другой, так и больше.
Например, в листе 1 есть: "Viktor & Rolf Antidote" и "Victoria’s Secret SO IN LOVE ". Им соответствуют значения на втором листе: "Viktor & Rolf" и "Victoria’s Secret" соответственно. "Amouage" во втором листе относится и к Испании и к Германии. Почему Вы в первом листе "Amouage Ciel" и "Amouage Epic" отнесли к Германии, а не к Испании - известно только Вам и программе этого никак не объяснить. Отсюда вывод - 100% соответствия в таком барахле Вам ни формулы, ни коды не дадут.
Но можно попробовать применить такую формулу массива:
=ИНДЕКС(Лист2!$B$1:$B$10;ПОИСКПОЗ(ИСТИНА;НЕ(ЕОШ(ПОИСК(Лист2!$A$1:$A$10;A2)));0))

Если же применять ВПР, как у Вас на листе: =ВПР(A2;Лист2!A:B;2;1)
то надо было статью читать внимательно, а не абы как. Там написано, что при последнем аргументе 1 или ИСТИНА таблица значения должна в обязательном порядке быть отсортирована по возрастанию. Чего Вы не сделали.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
Страницы: 1
Читают тему (гостей: 1)
Наверх