Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
СуммЕсли неадекватно считает
 
Есть цифровая кодировка финансовых позиций, но список этой кодировки стоит с форматом ТЕКСТ
В случае если код типа
2.07 - позиция второго уровня вложения
или
2.01.03.01 - позиция четвертого уровня вложения

то СУММЕСЛИ или СУММЕСЛИМН считает так как и положено - находит искомое значение и суммирует если таких значений несколько.

Но если искомый код такого типа
2.04.13 - позиция третьего уровня вложения

то, несмотря на то, что формат стоит текстовый, эксель насколько "умный", что видимо все равно считает это как дату и подсчет суммы вообще неадекватный.

Как можно обойти эту проблему, если учесть, что кодировку поменять - это не вариант.
Заранее спасибо за помощь.
 
Да, он считает 2.04 за дату 2.04.2013, что по его мнению подходит под критерий(который он воспринимает как дату в тектовом формате). Можно заменить СУММПРОИЗВ:
=СУММПРОИЗВ((A133:A319=F23)*(C133:C319))
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
не получается(
ошибка #ЗНАЧ!
 
Цитата
не получается( ошибка #ЗНАЧ!
Однако... ;)
summ_zxc.png (24.98 КБ)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
хм... прошу прощение
формула сдвинулась и ссылка поднялась выше, где в качестве одного из значений был текст, посему и выдало ошибку

PS Спасибо за помощь)
Изменено: AleX_X89 - 22 Окт 2013 15:18:40
Страницы: 1
Читают тему (гостей: 1)
Наверх