Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Не работают в паре sum и address
 
Друзья, помогите разобраться, пожалуйста!
В функции SUM есть потребность использовать измеряемый диапазон.
Отдельно фунция ADDRESS работает наура. выдает ссылку на ячейку.
но когда вставляю эту ссылку на ячейку в функцию SUM - ошибка(((
Как пишу (покажу на примере условного диапазона A1:A1):
=sum(address(1,1))
или
=sum(address(1,1)&":"&address(1,1))

Нужен больше второй вариант, но и первый не работает. Подскажите, где дырка в голове, а?
 
Код
=СУММ(ДВССЫЛ(АДРЕС(1;1)&":"&АДРЕС(1;3)))
Excel 2013
 
=SUM(INDIRECT(ADDRESS(1,1)))
Я сам - дурнее всякого примера! ...
 
Джентельмены, спасибо!
 
=СУММ(ИНДЕКС(A1:A10;1))
 
excel 2010
Не понимаю, почему не работает формула:
=SUM(INDIRECT("Sheet3:Sheet5!A1"))

Помогите, пожалуйста...
Изменено: Beso Shioshvili - 30 Мар 2015 08:16:41
 
В роде бы, должно получится:
=SUM(Sheet3:Sheet5!A1)
 
Все гости и пользователи удалились :cry:
Модераторы, может, вы помогите? :sceptic:
 
Цитата
Beso Shioshvili написал: ... должно получится:..
Что? Почему? Зачем?.. ;)
ps Данные на 4, 5 листах заполните на всякий случай.
pps В поиск - трехмерные ссылки.
Изменено: Z - 30 Мар 2015 08:58:54
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
не знай с текстом не получается если листы именованы только цифрой то так
Лень двигатель прогресса, доказано!!!
 
Заполнил...
Ну и что?
 
получилось
Код
=СУММПРОИЗВ(--Ч(ДВССЫЛ("Sheet"&СТРОКА(ДВССЫЛ(D1&":"&E1))&"!A1")))
Изменено: Сергей - 30 Мар 2015 09:12:35 (The_Prist в одной из тем писал на соседнем форуме)
Лень двигатель прогресса, доказано!!!
 
Сергей, а если там другие имена?..
 
задействована макрофункция по извлечению имен листов (смотрим в диспетчере имен) можно и без него но наименования листов надо писать вручную, диапазон листов задается вручную
Лень двигатель прогресса, доказано!!!
 
Спасибо большое, Сергей :)
 
Сергей, для чего sumif, если и sum работает?
Вместо
=SUMPRODUCT(SUMIF(INDIRECT(E3:E5&"!A1";);"<>0";INDIRECT(E3:E5&"!A1";)))
вставил
=SUMPRODUCT(SUM(INDIRECT(E3:E5&"!A1";)))
Страницы: 1
Читают тему (гостей: 1)