Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
счетесли работает с буквами но не работает с цифрами
 
Добрый день коллеги,
столкнулся с такой штукой, подсчитать количества встречающихся сочетаний букв или цифр, но с буквами в клетке, возможно.
примерно так: =СЧЁТЕСЛИ(A:A;"*202*" ;)  
но если в клетке только цифры (например 2023000675 и т.п.) то функция не работает.

подскажите кто знает, как заставить считать часть цифр?
Изменено: Андрей Р - 11 Ноя 2013 19:33:53
 
Добрый день.
Выложите нормальный пример колонка А - "до", колонка Б - "после".
Цитата
как заставить считать часть цифр?
и что же Вы этим хотели сказать?
 
Код
=СУММ(--(ЕСЛИ(ЕОШ(ПОИСК("202";A1:A8;1));0;ПОИСК("202";A1:A8;1))>0))

Формула массива.
Изменено: SkyPro - 11 Ноя 2013 14:04:31
 
Формат ячеек - Текстовый - F9
Согласие есть продукт при полном непротивлении сторон.
 
Даже вот так:
Код
=СУММПРОИЗВ(--(НЕ(ЕОШ(ПОИСК("202";A1:A13;1)))))

Не массивная.
Изменено: SkyPro - 11 Ноя 2013 14:07:16
 
Цитата
SkyPro пишет:
Даже вот так:
:o  тоже подумал через поиск
Цитата
Sanja пишет:
Формат ячеек - Текстовый - F9
для чисел не помогает
Изменено: Антон - 11 Ноя 2013 14:16:22
 
Символы подстановки работают только для текста. Для чисел не прокатывает. Самый простой вариант:
СУММПРОИЗВ или:
-в отдельный столбец записать формулу, где сцепить данные с пробелом(чтобы пробел на конце получился). Тогда СЧЁТЕСЛИ сможет искать по таким данных, применяя символы подстановки.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
SkyPro, спасибо!
Формула работает, но все таки функция "счетесли" только с цифрами не работает,
см вложение.
если есть в клетке хоть одна буква то работает, если нет то не работает.
 
Я вроде написал уже, что подстановочные символы работают исключительно с текстом. И применить к числам можно только если из числе сотворить явный текст.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
SkyPro, вставил данную формулу в отчет (140 строк с данной формулой) и заметил особенность
при работе, по данной формуле, ПК грузится на 100% и ексель виснет на несколько секунд.

то есть вписываю один номер и на 10-15 сек комп не доступен.
 
Цитата
The_Prist пишет: .. подстановочные символы работают исключительно с текстом.
был не внимателен, сейчас буду прицеплять пробел.
но к примеру поиск через "найти и выделить" части цифр ищет нормально.
 
Найти и выделить по другому принципу работает. Для него все текст. А СЧЁТЕСЛИ производит внутри приведение типов. Это позволяет вести подсчет не только с подстановочными символами для текста, но и при помощи операторов сравнения для чисел:
>
<
>=
<=
=СЧЁТЕСЛИ(A1:A10; ">0") - подсчитает кол-во положительных значений, не считая нуль.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
с начало и написал со "счетеслимн" указав возможный диапазон, но столкнулся с разным кол-вом знаков при считывание разных товаров, и получилось что один поглощает другой, при счет.
сейчас сделал сцепление с пробелом и далее просто "счетесли", форма выгружается из SAP немного долго (за счет большого кол-ва формул по сцепить), но зато работает потом быстро.

огромное спасибо за разъяснение и помощь!!!
 
Андрей Р, кнопка "цитировать" не для того, чтобы посетители БЕЗДУМНО на нее нажимали!
Страницы: 1
Читают тему (гостей: 1)