Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1 2 След.
RSS
Выбор даты по условию из диапазона дат.
 
Здравствуйте уважаемые знатоки Excel.
Столкнулся с проблемой выбора получившейся даты по условию.
В таблице в диапазоне B2:M2 расположены условия, в диапазоне B8:M8 набор дат, из которых
необходимо выбрать дату  согласно условию. Например, если есть дата в диапазоне B8:M8
соответствующая январю 2014 (ячейка M2) то она должна отобразиться в ячейке M3 и т.д.

P'S.
Перепробовал всякие варианты ничего не выходит.
Очень рассчитываю на вашу помощь.
Alexander
 
формула массива
Код
=ИНДЕКС($B$8:$M$8;;ПОИСКПОЗ(МЕСЯЦ(B$2);МЕСЯЦ($B$8:$M$8);0)) 

Изменено: китин - 16 Янв 2014 10:58:27
не пинайте очень сильно,я пытаюсь научиться
 
Кроме как в столбце М все остальные данные абсолютно неверные...
Если автоматизировать бардак, то получится автоматизированный бардак.
 
?????как это? :?:
не пинайте очень сильно,я пытаюсь научиться
 
С помощью допстроки.
Век живи, век учись - два века проживешь!
 
ждем ТСа.пусть рассудит :)
не пинайте очень сильно,я пытаюсь научиться
 
Второй вариант, если я неправильно понял условие задачи:
Век живи, век учись - два века проживешь!
 
Руслан, огромное спасибо Вам!
Самих данных с датами несколько тысяч строк.  :(  
Надеялся, что можно реализовать решение в одной формуле.
Придется как-то выкручиваться.
Еще раз большое спасибо!

Но все-же в ячейке должна отображаться дата 29.12.2014
из диапазона B8:M8.
Изменено: Александр Худяков - 16 Янв 2014 08:48:03
Alexander
 
Александр вы бы хоть пояснили,что не так.истелесно ведь ;)
не пинайте очень сильно,я пытаюсь научиться
 
Цитата
Надеялся, что можно реализовать решение в одной формуле.
Наверняка можно, это всего лишь вариант.
Кстати, какой подошел-то?
Век живи, век учись - два века проживешь!
 
Цитата
?????как это? :?:
Не переживайте! Для того, чтобы оценить, надо узнать как готовят и "едят" формулы массива... ;) Вот тогда, мо быть, и спасибы дождетесь. Хотя, не ради одного ТС планетяне помогают - другим пригодятся. Они и "подавитель" н/д по случаю сами подключат. Как вариант, однако...
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Цитата
Вот тогда, мо быть, и спасибы дождетесь
Z не в спасибах дело то.дело в тренировке и изучении.хочется знать что не так сделал и что не так понял  :D
Изменено: китин - 16 Янв 2014 09:06:35
не пинайте очень сильно,я пытаюсь научиться
 
Цитата
Но все-же в ячейке должна отображаться дата 29.12.2014
из диапазона B8:M8.
и что тогда не так в моей формуле?
не пинайте очень сильно,я пытаюсь научиться
 
Цитата
хочется знать что не так сделал и что не так понял
Планета еще не научила - не спешите наперегонки рыбу раздавать до тех пор, пока нет ясности в хотелке ТээС'а?!
ps А если тренировки личной ради, то и вылизывать решение, наверное, надо как для себя любимого... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Постараюсь еще раз пояснить.
Если в диапазоне В2:М2 указаны даты, то формула на основании ячеек  должна просматривать даты из В8:М8
и выбирать дату из указанной ячейки например из М2 01.12.2014 но от 01.12.2014 до 31.12.2014.
Alexander
 
Александр,или я туплю или лыжи не едут.что конкретно не так в моем файле?пост№2.вручную поставьте в вашем файле что вы хотите
не пинайте очень сильно,я пытаюсь научиться
 
ТС хочет чтобы в результате на конкретно приложенном примере данные были только в закрашенной ячейке, в оставльных пусто.
Ваше решение проверяет только совпадение месяца, нужно еще и год чтобы совпадал.
Век живи, век учись - два века проживешь!
 
формула массива:
Код
=МИН(ЕСЛИ(B8:M8>=M2;ЕСЛИ(B8:M8<=КОНМЕСЯЦА(M2;0);B8:M8)))
 
а год то я и не посмотрел.тупимс потихоньку :oops:
не пинайте очень сильно,я пытаюсь научиться
 
Цитата
формула массива:...  
С "баксами" -  уютнее, однако... ;)
Код
=МИН(ЕСЛИ($B$8:$M$8>=B2;ЕСЛИ($B$8:$M$8<=КОНМЕСЯЦА(B2;0);$B$8:$M$8)))
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
По данному примеру (если так и будет - числа в порядке возрастания) то можно и не массивную:
Код
=ЕСЛИ(ГПР(КОНМЕСЯЦА(M2;0);$B$8:$M$8;1;1)>M2;ГПР(КОНМЕСЯЦА(M2;0);$B$8:$M$8;1;1);"")
 
ну тогда вот такой монстр получился(ну охота мне с ИНДЕКС побаловаться) формула массива
Код
=ЕСЛИ(ЕНД(ИНДЕКС($B$8:$M$8;;ПОИСКПОЗ(ТЕКСТ(B2;"ММ.ГГГГ");ТЕКСТ($B$8:$M$8;"ММ.ГГГГ");0)));"";ИНДЕКС($B$8:$M$8;;ПОИСКПОЗ(ТЕКСТ(B2;"ММ.ГГГГ");ТЕКСТ($B$8:$M$8;"ММ.ГГГГ");0)))

Изменено: китин - 16 Янв 2014 10:58:13
не пинайте очень сильно,я пытаюсь научиться
 
Руслан А.  во 2-ом примере все великолепно работает, просто я в спешке просмотрел. Прошу прощения. Спасибо огромное.
Nic70y  попробовал Ваш вариант заполнив диапазон В3:М8, при изменении в диапазоне с исходными датами, на другие даты
в пределах 2014 года, формула не работает.

Всем огромное спасибо за ваше участие и помощь, даже в рамках этих консультаций почерпнул для себя не мало полезного.
Alexander
 
Цитата
попробовал Ваш вариант...формула не работает.
Какая/ой, где? Показать можно?!
ps Если извилины (свои) не напрягать, форум читать с пятое-на-десятое, то да - мо быть... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
китин - вариант 3333(2).xls просто прелесть!  :)
Alexander
 
а если подшлифовать(для Эксель 2007 и выше)
Код
 =ЕСЛИОШИБКА(ИНДЕКС($B$8:$M$8;;ПОИСКПОЗ(ТЕКСТ(B2;"ММ.ГГГГ");ТЕКСТ($B$8:$M$8;"ММ.ГГГГ");0));"")
не пинайте очень сильно,я пытаюсь научиться
 
Цитата
попробовал Ваш вариант
о каком варианте речь?
 
Nic70y - вот этот у меня не получился.
=ЕСЛИОШИБКА(ИНДЕКС($B$8:$M$8;;ПОИСКПОЗ(ТЕКСТ(B2;"ММ.ГГГГ");ТЕКСТ($B$8:$M$8;"ММ.ГГГГ");0));"")
За 14.56.xls (29 КБ) огромное спасибо, все великолепно.

Еще раз всем светлым головам спасибо!  
Alexander
 
Александр а вы про формулу массива не забыли?

Код
=ЕСЛИОШИБКА(ИНДЕКС($B$8:$M$8;;ПОИСКПОЗ(ТЕКСТ(B2;"ММ.ГГГГ");ТЕКСТ($B$8:$M$8;"ММ.ГГГГ");0));"") 
не пинайте очень сильно,я пытаюсь научиться
 
китин
конечно забыл... спасибо большое!
Alexander
Страницы: 1 2 След.
Читают тему (гостей: 1)
Наверх