Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Разнести текст ячейки на 2 столбца
 
Добрый день.
Нужно разделить текст ячейки (все ячейки с разной длиной слов и количеством слов)
Нужно разделить на две ячейки в первом все что до кода, второй код (он имеет постоянно количество символов)
 
Спасибо за помощь :)
 
ЛЕВБ, ПРАВБ
см. файл:
 
:?:
Код
=ПРАВСИМВ(A1;10)
=ЛЕВСИМВ(A1;ДЛСТР(A1)-11)
Согласие есть продукт при полном непротивлении сторон.
 
Nic70y, КРУТО!!!!
Спасибо  :)  
Тему можно закрыть.
 
готово
 
Devicehunter, скажите, пожалуйста, а код всегда идёт в конце ячейки и всегда одной длинны?

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Цитата
JayBhagavan пишет:
Devicehunter , скажите, пожалуйста, а код всегда идёт в конце ячейки и всегда одной длинны?
Да, именно так :)
 
Здравствуйте. Может и мне поможете?
Нужно текст разделить на "до и после первого слэша" и на "после второго слэша"
Спасибо.
Изменено: as is - 11 Июл 2014 09:49:28
 
as is, пробуйте.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Как быстро!
JayBhagavan, спасибо большое, то что нужно!
 
Доброго времени суток.
Есть большая просьба помочь разделить формулами по ячейкам такой образец таблицы в приложении.
Ячейка с телфоном и именем надо разделить по столбцам, но если нет имени, то продублировать в эту ячейку также номер телефона.
Заранее благодарю!
 
Serg@li,
=ЕСЛИОШИБКА(ПСТР(A1;1;НАЙТИ(" ";A1));A1)
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(A1;ПСТР(A1;1;НАЙТИ(" ";A1));"");A1)
 
ArtyrH, какой вы молодец, огромное спасибо! Супер! ))
Страницы: 1
Читают тему (гостей: 1)
Наверх