Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование: диапазон суммирования несколько столбцов
 
Возможно ли суммировать значения по одному условию из нескольких столбцов?
 
А в чём трудность то?

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
а если так

Код
=СУММ(СУММЕСЛИ($A$3:$A$12;$A16;$B$3:$B$12);СУММЕСЛИ($A$3:$A$12;$A16;$C$3:$C$12);СУММЕСЛИ($A$3:$A$12;$A16;$D$3:$D$12)) 
Лень двигатель прогресса, доказано!!!
 
Столбцов в оригинальном листе 15, листов 10 - формулы получаются очень длинными.
 
тогда вот так

Код
=СУММ((A16=$A$3:$A$12)*($B$3:$D$12)) 
вводить как формулу массива
Изменено: Сергей - 21 мар 2014 12:54:30
Лень двигатель прогресса, доказано!!!
 
Был невнимателен. Каюсь.
Изменено: JayBhagavan - 21 мар 2014 13:01:34

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
{2;3;4;0;6;0;0} - 0, это столбцы, которые не надо суммировать. Порядок номеров следует соблюдать. кол-во номеров в скобках должно быть равным кол-ву столбцов с суммами(без разрывов).
Код
=СУММПРОИЗВ(($A$3:$A$12=A16)*(СТОЛБЕЦ($B$1:$H$2)={2;3;4;0;6;0;0})*($B$3:$H$12))
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Всем спасибо.  :)
The_Prist, Ваш вариант отличный.  :{}
 
Здравствуйте!
Вчера расширяла сознание этим примером  :)  Большое спасибо.

Но для своего решение придумать не смогла, помогите, пожалуйста.
У меня похожая задача, только еще и столбцы для суммирования не фиксированы. Т. е. в зависимости от параметра суммируется разное количество столбцов.
Столбец с промежуточным результом и простое суммесли по нему использовать как бы невозможно.
 
=СУММ(ИНДЕКС($B$2:$B$11;ПОИСКПОЗ(A15;$A$2:$A$11;0)):ИНДЕКС($B$2:$I$11;ПОИСКПОЗ(A15;$A$2:$A$11;0);$B$13))
 
Я сейчас это не спеша пойму. Но в моем примере эта формула по "1" дает неверный результат. Там должно быть 2400, считается 1200. Она считает только единичку в 5-й строке, из 7-й строки можно удалить все данные, результат останется 1200
 
Не посмотрел, что значения столбца А повторяются. Формула массива (ввод Ctrl+Shift+Enter):
=СУММ(ЕСЛИ($A$2:$A$11=A15;$B$2:ИНДЕКС($B$11:$I$11;$B$13)))
 
О, я когда-нибудь тоже стану добрым волшебником :)
Спасибо огромное!
 
Всем привет. Друзья помогите с формулой. Для счета цифр формулу родил, а счет букв в массиве не получается родитьмой пример.xlsx (11.52 КБ) .
=СУММ(ЕСЛИ($A$3:$A$7=A14;$B$3:$K$7))
 
=СУММ(--ЕСЛИ($A$3:$A$7=$A14;$B$3:$K$7="к"))
 
Код
=СЧЁТЕСЛИ(ИНДЕКС($B$3:$K$7;ПОИСКПОЗ($A14;$A$3:$A$7;););C$13)
для суммы лучше так
=СУММ(ИНДЕКС($B$3:$K$7;ПОИСКПОЗ($A14;$A$3:$A$7;);))
Изменено: V - 24 май 2017 14:52:25
 
vikttur,V, Спасибо огромное! Круто.
 
Вариант:
=СЧЁТ(1/ЕСЛИ($A$3:$A$7=$A14;$B$3:$K$7=C$13))
 
vikttur,забрал на заметку. Еще раз спасибо.
Страницы: 1
Читают тему (гостей: 1)
Наверх