Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Многоразовый ВПР по порядковому номеру
 
Добрый день!

В продолжении темы Многоразового ВПР - http  :/  /www.planetaexcel.ru/techniques/2/81/.
Формула замечательная, работает, но извлекает значения из таблицы последовательно.
Подскажите, пожалуйста, как бы сделать так, чтоб учитывался порядковый номер и значения выводились не последовательно, а в соответствии с порядковым номером.
Заранее спасибо.

Пример вот:
 
А отсортировать исходные данные по порядковому номеру, а затем формулу применить не вариант?
Согласие есть продукт при полном непротивлении сторон.
 
Отсортировать по порядковому номеру в исходной таблице и все норм
Изменено: Finswimmer - 17 Июл 2014 16:41:20
 
Нет, сортировка не подойдет.
Объяснять почему - очень долго. Вкратце, данные собираются из различных файлов и отсортировывать данные в исходном файле нет возможности.
Пример для наглядности приведен.
Хотелось бы понять - можно это как-то с помощью формул решить...
 
ФМ:
Код
=ИНДЕКС($B:$B;МАКС(СТРОКА($A$2:$A$16)*($A$2:$A$16=$E$2)*($C$2:$C$16=$I6)))
Изменено: JayBhagavan - 17 Июл 2014 18:05:57

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Срабатывает, но только на первый порядковый номер.
 
Забыл указать, что ФМ.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
?
 
[USER=40201]JayBhagavan, здорово! Спасибо!

Я сообразила, что ФМ. У меня не получилось изменить ссылку на порядковый номер, вводя массив, ссылка менялась во всех строках на первый порядковый номер.
Подскажите, пожалуйста, как Вы проставили разные ссылки в каждой строке?

[/USER]
Страницы: 1
Читают тему (гостей: 1)
Наверх