Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Средняя за последние 5 дней.
 
Был такой вопрос "как рассчитать среднее число из последних пяти введенных".
Мастера данного форума помогли. Но помогли по столбцам вот такой формулой.
Код
=СУММ(СМЕЩ($B$6;ПОИСКПОЗ(9E+307;$B$6:$B$50;1)-5;;5;))/5
Как вот эту формулу переделать, чтобы она считала по строкам?
Пробую просто менять смещения строк на столбы и высоту на ширину, получается не пойми что, непонятно откуда берутся цифры.
Данные вносятся каждый день.
 
=СРЗНАЧ(ИНДЕКС(A7:N7;ПРОСМОТР(9E+307;A7:N7;СТОЛБЕЦ(A7:N7))-4):ИНДЕКС(A7:N7;ПРОСМОТР(9E+307;A7:N7;СТОЛБЕЦ(A7:N7))))
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Спасибо, Владимир, но почему эта формула вываливается в ошибку, если данных остается в 3, 2, 1 ячейке?

Код
СТОЛБЕЦ(A7:N7))-4)
-4 что означает?
И если это важно, то данные в ячейках выводятся формулами и гиперссылками.
Вот чтобы было наглядней тот файл в котором нужно сделать.
Изменено: 4vaker - 5 Сен 2014 17:10:48
 
Лююююдииии, помогите!!!!
Вы же шарите!!
И исходник есть. Его переделать только надоооо!!
=СУММ(СМЕЩ($B$6;ПОИСКПОЗ(9E+307;$B$6:$B$50;1)-5;;5 ;) )/5
Вот это построчно, а как по столбам???? Уже всё попеременял, не получается.
 
Без контроля что заполненных столбцов может быть и меньше 5.
Код
=СУММ(СМЕЩ($A$7;;ПОИСКПОЗ(9E+307;7:7;1)-5;1;5))/5 
 
Благодарю, уважаемые!
Применил формулу выше (пост Игоря), а недостающие дня взял с прошлого месяца, чтобы всегда было 5 =))
Не стану больше напрягать=)
Изменено: 4vaker - 5 Сен 2014 20:07:19
Страницы: 1
Читают тему (гостей: 1)
Наверх