Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Можно ли указать диапазон значений в критерий функции СУММЕСЛИ, вопрос
 
Ребят, не могу разобраться, подскажите, можно ли указать диапазон значений в критерий функции СУММЕСЛИ или СУММЕСЛИМН!?
1 10
2 20
3 30
4 40
5 50
Диапазон:(1,2)
Нужно Суммировать второй столбец (10+20) Если в первом столбце значение  1 или 2. В реальном примере каонечно не 1 и 2, там диапазон намного больше. Вот мне и надо чтобы функция сравнила, попадает ли значение из первого столбца в заданный диапазон?
Изменено: viton-zizu - 18 Фев 2015 06:17:47
 
в СУММЕСЛИМН можно указывать несколько критериев отбора для указания диапазона мне больше нравится СУММПРОИЗВ

Код
=СУММПРОИЗВ((A1:A10>=1)*(A1:A10<=3)*B1:B10) 
Лень двигатель прогресса, доказано!!!
 
Цитата
в первом столбце значение 1 или 2. В реальном примере каонечно не 1 и 2,
Покажите хоть что-нибудь
Цитата
мне больше нравится СУММПРОИЗВ
Ну да. Для ленивых  :)  
СУММПРОИЗВ имеет большой недостаток - тяжелая в вычислениях, на уровне формул массива. Если есть легкая замена, зачем?
 
Ну, Вы же диапазон все равно куда-то запишете? В отдельную таблицу? Ну и посчитайте в соседнем столбце этой таблицы для каждого значения диапазона - =СУММЕСЛИ(). И потом - сумму по этому столбцу.
А если Вы диапазон напрямую в формулу записываете, тогда чем плоха =СУММЕСЛИМН()?...
Изменено: Михаил Лебедев - 18 Фев 2015 11:19:50
 
Все таки больше подошла СУММЕСЛИМН(), хотя в итоге потребовалось слишком много операций, чтобы узнать диапазон критерия для суммирования и решил реализовывать на vba!
 
Код
=СУММПРОИЗВ(СУММЕСЛИ(A1:A10;{1;2}];B1:B10))
или
Код
=СУММПРОИЗВ(СУММЕСЛИ(A1:A10;D1:D10;B1:B10))
в D1 :D10 - условия; можно и пустые ячейки; можно и в строку.
Изменено: Михаил С. - 18 Фев 2015 16:00:51
 
Нет, все-таки не удержусь, напишу ☺
Михаил С., добавил себе Ваши решения в копилочку. Спасибо. За "красиво и лаконично". Сам я не один раз пытался придумать такую комбинацию. Не получалось...
 
=СУММПРОИЗВ(--($A$21:$A$73=F3:J3)*$K$21:$K$73)
Думаю это тоже вариант.
 
Для коллекции:
Код
=СУММЕСЛИ(...;">=1";...)-СУММЕСЛИ(...;">2";...)
 
Михаил С., так короче
Код
=СУММ(СУММЕСЛИ(A1:A10;{1;2};B1:B10))
Алексей М.
 
АlехМ, да, но это формула массива. СУММПРОИЗВ не требует массивного ввода.
Эта формула плохо (не всегда корректно) работает с условиями больше\меньше.
 
Михаил Витальевич С., Эта тоже не требует массивного ввода.
Алексей М.
 
АlехМ, ну да, не требует... На планшете не разглядел фигурные скобки.
 
Nurmukhammedus, минусы лишние.
Страницы: 1
Читают тему (гостей: 9)
Наверх