Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Условное форматирование по значению в других ячейках
 
Собственно такая проблема, имеется ряд некоторых значений, на их основе рассчитывается доверительный интервал и сравнивается с исходным значением - результат + или - в зависимости от того попало значение в доверительный интервал или нет.
Каким образом можно подсветить исходную ячейку на основании значения соседней с + или -   ?
 
Цитата
Stolz написал: Собственно такая проблема,
Проблема может быть решена при наличии файла примера
Лень двигатель прогресса, доказано!!!
 
Выкладываю пример, хотя не понимаю зачем он. Есть 2 ячейки, А1 и В1. Как мне сделать так, что бы А1 имела определенный формат в зависимости от значения в ячейке В1?

В примере красные ячейки (C-G) - исходные, зеленые (L-P) - это те, на основании значения которых надо отформатировать исходные ячейки
 
Цитата
Выкладываю пример, хотя не понимаю зачем он
Для того, чтобы помогаюие не придумывали и не рисовали сами вместо Вас.

Условное форматирование для диапазона, формула:
=L2="+"
 
Благодарю, не знал что можно таким образом форматировать :)
 
Подскажите, а если пойти дальше, можно вообще избавиться вообще от ячеек с проверкой данных?
Пробую формулу =ABS(I$2-C2)>K$2 но она на весь диапазон распространяется не изменяясь. Можно ее как-то растянуть, или каждое правило вручную вбивать?
 
=ЕСЛИ(ABS($I2-C2)>$K2;C2<>0)
Условия лучше переставить местами - меньше вычислений в случае C2=0
 
=И(ABS($I2-C2)>$K2;C2<>0) так то что надо получилось, спасибо за помощь
Изменено: Stolz - 24 Фев 2015 21:33:19
 
Нет, лучше так:
=ЕСЛИ(C2<>0;ABS($I2-C2)>$K2)
 
Не понимаю, зачем там ЕСЛИ. По идее условное форматирование уже предполагает ЕСЛИ (формула верна; форматируем)

UPD: Все, понял. Спасибо
Изменено: Stolz - 24 Фев 2015 22:07:20
Страницы: 1
Читают тему (гостей: 1)