Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск текста по ячейкам и вставка в другую ячейку
 
Люди помогите плиззз! Нужно срочно!
Нужно в столбец "Goods" G2 залить формулу которая будет искать  "Material" В2 в данный момент это 5002896 по сталбцу  Н и вставлять полностью все наименование в G2 т.е. берем ячейку В2 (5002896) и ищем по первом символам в ячейке Н и вставляет в ячейку G2
 
Примерно так
Код
=ИНДЕКС($F$1:$F$249;ПОИСКПОЗ(B2&"*";$F$1:$F$24;0))

Изменено: МВТ - 24 Фев 2015 23:19:00
 
=ПОДСТАВИТЬ(ВПР(B2&"*";$F$1:$F$37;1;0);B2;"")
Лень двигатель прогресса, доказано!!!
 
спасибо огромное))) все работает!
 
Sidor888, не все работает у вас в кодах материала присутствуют такие коды как 500 обе формулы возьмут первое попавшееся с кодом начинающимся на 500 а дальше хоть трава не расти яб рекомендовал добавить проверку по длинне кода
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)