Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вычисления премий с учетом среднего значения
 
Подскажите, пожалуйста, как сделать при помощи формулы  и какой, следующий подсчет, при этом не создавая новых ячеек.  Имеется несколько позиций, каждая позиция имеет свое значение в диапазоне нескольких дней. Вначале нужно вычислить среднее значение, если среднее значение >=2, то премия 1000, если >=4, то 2500, если = 5, то 5000. То есть в итоге, в отдельной ячейке, должна фиксироваться только конечная премия, например, 1000.  
Изменено: Aleksey Belugin - 25 Фев 2015 14:52:45
 
Код
=ВЫБОР(ПОИСКПОЗ(СРЗНАЧ(B3:E3);{0;2;4;5};1);0;1000;2500;5000)
Как-то так?
Кому решение нужно - тот пример и рисует.
 
Aleksey Belugin, Вы бы собрались с мыслями да приложили реальный пример с реальной проблемой и реально-возможным решением... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Кросс- http://www.excelworld.ru/forum/2-16075-1
ps Правила дочитать до конца сил не хватило... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Код
=ВПР(СРЗНАЧ(B2:E2);{0;0:2;1000:4;2500:5;5000};2;1)
для разнообразия
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)