Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Найти число, максимальное по модулю
 
Привет, у меня проблема. A1:A5 наибольшее значение в диапазоне, я считаю. Но A1:A5,B7:B9,C11:C13 диапазона нужно найти максимальное количество ( - ,+), без ограничений. Результат ( -4554 )
Изменено: liny1 - 26 Фев 2015 11:25:25
 
Без Вашего файла разобраться?
 
А вот и формула:
Код
=ЕСЛИ(МАКС(A1:C13)<>МАКС(ЕСЛИОШИБКА(ABS(A1:C13);0));-МАКС(ЕСЛИОШИБКА(ABS(A1:C13);0));МАКС(ЕСЛИОШИБКА(ABS(A1:C13);0)))
Естественно забиваем с помощью ctrl+shift+enter (формула массива).
Изменено: Все_просто - 26 Фев 2015 11:01:14
С уважением,
Федор/Все_просто
 
=ЕСЛИ(МАКС(A1:C13)<ABS(МИН(A1:C13));МИН(A1:C13);МАКС(A1:C13))
 
Все_просто, Формула правильно, спасибо. Но только вызов A1:A5,B7:B9,C11:C13 должен диапазоне. C10, -48445 если я напишу неверный результат выходит.
 
Я что-то не понял? Моя формула не работает?
 
vikttur, A1:A5, B7:B9 , C11:C13 только в этой области, найти Максимальное число, должны были быть. A1:C13 сделает поиск среди.
 
поменяйте диапазоны в формуле vikttur на свои ▼
=ЕСЛИ(МАКС(A1:A5;B7:B9;C11:C13)<ABS(МИН(A1:A5;B7:B9;C11:C13));МИН(A1:A5;B7:B9;C11:C13);МАКС(A1:A5;B7:B9;C11:C13))
 
Понял, нужно максимальное в разорванных диапазонах. Какие проблемы?
=ЕСЛИ(МАКС(A1:A5;B6:B10;C11:C13)<ABS(МИН(A1:A5;B6:B10;C11:C13));МИН(A1:A5;B6:B10;C11:C13);МАКС(A1:A5;B6:B10;C11:C13))
 
Михаил Лебедев,
vikttur,
Результат правильный,Спасибо
Страницы: 1
Читают тему (гостей: 1)