Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выбор по двум условиям + вхождение текста
 
Есть Таблица с колонками Товар, Наименование, Цвет. Необходимо: если товар = "Электроника" и в Наименовании = "*ASUS*" то в столбце Отбор напротив позиции ставить "Асус". Подскажите как реализовать?  
Тот, кто не желает поднять упавшего, пусть страшится упасть сам, ибо, когда он упадет, никто не протянет ему руку.
 
Код
=если(И(ячейка="электроника";левсимв(ячейка;поиск(" ";ячейка;1)-1)="ASUS");асус;"")
ну например в вашем примере нет электроники
Лень двигатель прогресса, доказано!!!
 
Вариант
Код
=ЕСЛИ(И(A2="Электроника";ПОИСК("ASUS";B2)>0);"АСУС";"")

Подтверждаю - Электроника в примере отсутствует
Согласие есть продукт при полном непротивлении сторон.
 
Цитата
Сергей написал: в вашем примере нет электроники
Да, там Техника.
А если вместо ячейка = "электроника" поставить допустим Таблица[товар]="электроника"
Изменено: dobroff - 26 Фев 2015 21:56:19
Тот, кто не желает поднять упавшего, пусть страшится упасть сам, ибо, когда он упадет, никто не протянет ему руку.
 
Цитата
dobroff написал: А если вместо
А если взять и самому попробовать?
Согласие есть продукт при полном непротивлении сторон.
 
Ответ в приложении:

UPD: немного доработал
Изменено: Все_просто - 26 Фев 2015 13:02:38
С уважением,
Федор/Все_просто
 
Цитата
dobroff написал: Да, там Техника.
тогда почему у вас в отбор попало только 2 позиции а не 4
(на вопрос можно не отвечать эт так к качеству примера придираюсь)
Лень двигатель прогресса, доказано!!!
 
Немного изменил смысл, так как не ясно видимо сформулировал.

Необходимо: Если Таблица[Склад]=F2 И Таблица[Товар]="*Бытовая*" то G2="Бытовая", Если Таблица[Склад]=F2 И Таблица[Товар]="*Промышленная*" то G2="Промышленная" и т.д.
Тоесть тут необходимо учесть два условия Склад и вхождение одного из слов (Бытовая, промышленная и т.д.)
Хотелось бы не вводить формулу для каждой ячейки а протянуть для всего столбца G.
Изменено: dobroff - 26 Фев 2015 14:27:29
Тот, кто не желает поднять упавшего, пусть страшится упасть сам, ибо, когда он упадет, никто не протянет ему руку.
 
Цитата
vikttur написал: Сообщение №8 игнорируете?
в чём ошибка? нажал цитирование.
Изменено: dobroff - 27 Фев 2015 13:04:23
Тот, кто не желает поднять упавшего, пусть страшится упасть сам, ибо, когда он упадет, никто не протянет ему руку.
 
=ЕСЛИ(Таблица[Товар]="*бытовая*";"бытовая")
у меня выдаёт ЛОЖЬ
хотя бытовая фраза "бытовая" есть в столбце.
В чём ошибка?
Тот, кто не желает поднять упавшего, пусть страшится упасть сам, ибо, когда он упадет, никто не протянет ему руку.
 
Цитата
в чём ошибка? нажал цитирование.
В том, что цитировать нужно не просто "нажал кнопку", а с умом и тогда, когда нужно.

По вопросу: в условии ЕСЛИ нельзя указывать приблизительное соответствие. Вернее, можно, но без толку :)
 
dobroff, чем не устраивает вариант предложеный Sanja, с поиском
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)