Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
замена из левсимв, нужно выстроить замену если...
 
максимальные условия такие...1 числа из первого столбца что меньше 8 знаков и больше 13 знаков оставлять пустое поле.
2 если начало цифр 70 - оставлять пустое поле
3 если начало на 7, и не 11 символов то пустое поле
4 если в начале 89 а длина 11, то 8 менять на 7

это реально???
 
Код
=ЕСЛИ(И(ЗНАЧЕН(ЛЕВСИМВ(A2;2))=89;ДЛСТР(A2)=11);ЗНАЧЕН("7"&ПРАВСИМВ(A2;ДЛСТР(A2)-1));ЕСЛИ(ИЛИ(ДЛСТР(A2)<8;ДЛСТР(A2)>13;ЗНАЧЕН(ЛЕВСИМВ(A2;2))=70;
И(ЗНАЧЕН(ЛЕВСИМВ(A2;1))=7;ДЛСТР(A2)<>11));"";A2))


Проверяйте.
Кому решение нужно - тот пример и рисует.
 
Всё круто, а можно ещё добавить в формулу, чтобы добавлял 7 в начале где нет 8-ки. а ещё в идеале добавлял 7 перед 9 если знаков 10
Изменено: gemorolog - 27 Фев 2015 10:06:00
 
Может так. Не учтены хотелки сообщения 3.
Код
=ЕСЛИ(И(ДЛСТР(A2)>7;ДЛСТР(A2)<12;--ЛЕВСИМВ(A2;2)<>70);ЕСЛИ(И(--ЛЕВСИМВ(A2)=89;ДЛСТР(A2)=11);7&ПСТР(A2;2;10);A2);"")
Лучше так:
Код
=ЕСЛИ(И(ДЛСТР(A1)>7;ДЛСТР(A1)<12;--ЛЕВСИМВ(A1;2)<>70);ЕСЛИ(И(--ЛЕВСИМВ(A1)=8;ДЛСТР(A1)=11);7&ПРАВСИМВ(A1;10);A1);"")
И не знаю обязательно ли проверять в начале 89 или достаточно первой восьмерки, у меня 89 в первой формуле 8 во второй.
Изменено: gling - 26 Фев 2015 18:21:39
 
Очень круто которая просто с восьмёркой, но перед 10-ти числами если спереди 9-ка не ставит 7-ку(((
Изменено: gemorolog - 27 Фев 2015 12:56:04
 
Вы не цитируйте ответы, это не обязательно. Удалите все цитаты и так понятно о чем речь. Придут модераторы закроют тему до устранения, никто ответ не сможет вам написать. Исправьте заранее пока не закрыли. Насчет 9 проверю.
Можно так:
Код
=ЕСЛИ(И(ДЛСТР(A14)>7;ДЛСТР(A14)<12;--ЛЕВСИМВ(A14;2)<>70);ЕСЛИ(ДЛСТР(A14)=10;7&ПРАВСИМВ(A14;10);A14);"") 
Только не понятно, если 10 знаков и первый знак не 9, а 6 например, или любой другой, как быть, что должно отобразиться.
Изменено: gling - 27 Фев 2015 23:14:44
 
Друзья мои, так что с семёркой? вообще нереально?
 
Почему то в сообщении #4 не видно формулы. Это только у меня на компе или еще кто то не видит? Там такая формула =ЕСЛИ(И(ДЛСТР(A14)>7;ДЛСТР(A14)<12;--ЛЕВСИМВ(A14;2)<>70);ЕСЛИ(ДЛСТР(A14)=10;7&ПРАВСИМВ(A14;10);A14);"")  
Странно при вставке видно, а потом пропадает. Может модераторы подскажут в чем проблема.
Изменено: gling - 27 Фев 2015 18:44:23
 
Цитата
gling написал: Почему то в сообщении #4 не видно формулы.
Я вижу, с горизонтальным скроллингом. Лиса.
 
Цитата
Лиса.
Это что?
Извиняюсь, похоже я ошибся. Писал про одно- смотрел на другое, поэтому вкралась ошибка. В сообщении #6 мне не видно формулы, а вам?
 
Лиса - FF))
В #6 тоже формулу вижу. Тоже оформлена тегом кода.
 
Зашел с другого браузера, все равно не вижу формулы. Пока не мешает, но не понятно, почему. Впервые вставляю картину, что получится не знаю. Дааа, получилось красиво, на весь экран. Если надо убрать, уберу. Наверно что то с компом.
Вид.jpg (57.46 КБ)
Изменено: gling - 27 Фев 2015 23:10:03
 
Я вижу так:
Формула.jpg (83.27 КБ)
 
может дело в формуле? Пробую. Похоже дело в формуле или её длине. Одну формулу видно, другую нет.
Код
=ЕСЛИ(И(ДЛСТР(A14)>7;ДЛСТР(A14)<12;--ЛЕВСИМВ(A14;2)<>70);ЕСЛИ(ДЛСТР(A14)=10;7&ПРАВСИМВ(A14;10);A14);"") 
Код
=ЕСЛИОШИБКА(B2^3/14;0)
Юрий М Вашу картинку вижу, все нормально, но у меня не так.
Ниже пробный вариант. Странно как то отображается. В чем может быть причина? Может какой движок поставить? Я все обновления отключил, пока не будет необходимости не ставлю. Может возникла такая необходимость?
4.jpg (42.03 КБ)
Изменено: gling - 27 Фев 2015 23:31:50
 
Извиняюсь за беспокойство. Что то у меня с видео картой. При изменении изображения на экране (Ctrl+колесо мыши) формула пропадают или появляются. Стабильности нет, пропадает при разных размерах и появляются так же.
Изменено: gling - 27 Фев 2015 23:47:33
Страницы: 1
Читают тему (гостей: 1)