Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
циклы VBA
 
Всем привет!
Подскажите каким образом можно заполнить таблицу, подробно в файле пример)
 
Приветствую.
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$1:A2;A2)>1;"";1)
В H2 и тянуть вниз.
Кому решение нужно - тот пример и рисует.
 
=--(СУММЕСЛИ($A$1:$A1;$A2;H$1:H1)=0)

Если VBA не обязательно.
 
Вот так:
Код
Sub foo()
Dim rngInp As Range, rngOut As Range
Set rngInp = Application.InputBox("Enter some range(input)", Type:=8)
Set rngOut = Application.InputBox("Enter some range(output)", Type:=8)

Dim c As Collection: Set c = New Collection
Dim cell As Range, col As Integer

col = -rngInp.Column + rngOut.Column + 1
On Error Resume Next
For Each cell In rngInp

    c.Add cell.Value, cell.Value
    If Err <> 0 Then Err.Clear Else cell(1, col).Value = 1
    
Next cell
On Error GoTo 0
End Sub
С уважением,
Федор/Все_просто
 
Обязательно VBA, там еще много вещей буду цеплять к этому процессу)
 
Все_просто, спасибо, то что нужно!

P.S. Спасибо всем за участие и ваши решения!
Изменено: ALFA - 26 Фев 2015 16:35:02
 
ALFA, если там будет несколько процессов, то мой способ может и не подойти. Так как отключается проверка на ошибки при возможных ошибках с вашей стороны, макрос будет работать некорректно. Лучше использовать словарь через
Код
c = CreateObject("Scripting.Dictionary")
Потом смотрим по свойству
Код
c.exists(ключ)
Если ключ не существует - пишем единицу, если ключ есть - ничего не пишем.

Так что, если будете применять макрос сверху, действуйте с осторожностью.
С уважением,
Федор/Все_просто
Страницы: 1
Читают тему (гостей: 1)