Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формула ВПР присваивает одно значение разным критериям
 
Уважаемые форумчане, гляньте, пожалуйста, почему у меня формула ВПР так криво считает. Зеленым отмечено несколько примеров, где считает правильно, а красным - где нет, почему-то по ращным поисковым критериям выдает одинаковый результат, хотя все пары чисел уникальные. Спасибо!  
 
м.б. как-то связано с дробной частью, х.з.
ИНДЕКС+ПОИСКПОЗ тоже хромает при точном поиске
при этом если скопировать значение формулы из столбца К и поискать ручками на другом листе, находит... странно.
Изменено: Максим Зеленский - 26 Фев 2015 18:37:06
F1 творит чудеса
 
Тоже загадка, там там все отображаемые десятые совпадают. и одно равно другому = истина (даты).
Танцы с бубном: Попробуйте искомое значение (дату время) привести в таблице в которой ищете с такой же формулой ОКРВНИЗ.ТОЧН, тогда ВПР работает нормально.
Работать надо не 12 часов, а головой.
 
Может так попробовать.
Изменено: gling - 26 Фев 2015 19:09:44
 
Причина в этом


попробуйте так:
Код
=ВПР(--ТЕКСТ(K2;"ДД.ММ.ГГГ ч:м:с");'Hourly Outages'!$A$2:$B$59;2)
или так
Код
=ОКРВВЕРХ(ОКРВНИЗ.ТОЧН(F2+"1:00"; "1:00:00");0,0001)
(в соответствующих столбцах)
 
Спасибо всем! Попробовал вариант Михаил С. - работает!  
Страницы: 1
Читают тему (гостей: 1)