Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск последнего значения
 
Здравствуйте!
"ПОИСК" - часть большой формулы, вопрос - как "сказать" этой функции, чтобы она реагировала без ошибки там, где в искомом тексте 1 ИЛИ другой символ (к примеру те же 1 ИЛИ 2). С трюками вроде - * , ? , ~ пробовал - не получается. Если знаете решение, просьба рассказать. Спасибо.
 
выб приложили пример что хотите наверняка эти трюки не нужны для этой функции
Лень двигатель прогресса, доказано!!!
 
А через ЕСЛИ()?
=ЕСЛИ(ЕОШ(ПОИСК("мама";A1;1));ЕСЛИОШИБКА(ПОИСК("мыла";A1;1);"");ПОИСК("мама";A1;1))

Другое дело, что если в ячейке будет 2 значения сразу - найдет первое слева.
Кому решение нужно - тот пример и рисует.
 
Объясню подробнее. В приложении: столбец В3 (день сегодня 8) В5-В11 - дни недели, С6 - некое событие, где может быть 1 или 2, остальные символы в ПОИСКе пусть выдают ошибку. С14 - результат (сколько дней прошло после события). сейчас формула работает только если событие = 1 (что и записано в ПОИСКе).
 
не на данном примере в понимании не осилю для чего нужны подстановочные символы
Лень двигатель прогресса, доказано!!!
 
Не путайте. ПОИСК ищет в тексте, для диапазона - ПОИСКПОЗ
=B3-СУММ(ЕСЛИОШИБКА(ИНДЕКС(B5:B11;ПОИСКПОЗ({1;2};C5:C11;));))
 
vikttur, подставил вашу формулу в D14, что-то не то, надо получить количество дней прошедших от события (1 ИЛИ 2) в С5:С11 до сегодня В3.
 
Правильно. 8-5=3.
Вам нужно последнее значение? Где об этом раньше писали?
=B3-ПРОСМОТР(2;1/(C4:C12>0);B4:B12)
 
vikttur, спасибо ОГРОМНОЕ ))... все работает
Страницы: 1
Читают тему (гостей: 1)