Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет количества повторов каждого значения в одной формуле
 
Добрый вечер. Ситуация такая:
Есть столбец с данными. Некоторые значения имеют повторы. Нужно подсчитать сколько повторов у каждого значения, которые имеют дубликаты, проделать с каждым определенное действие (формула - "x^3/14", где "x", количество повторов у значения), а затем сложить. Сложность в том, что всё это необходимо сделать в одной формуле, в одной ячейке.
Прикрепил пример.
 
Здравствуйте.
Есть вариант в файле.
Цитата
всё это необходимо сделать в одной формуле
Про одну формулу не сразу уловил. Можно записать так:
Код
=ЕСЛИОШИБКА(ЕСЛИ(СЧЁТЕСЛИ(Пример!$B$3:$B$12;ответ!A2)>1;СЧЁТЕСЛИ(Пример!$B$3:$B$12;ответ!A2);"")^3/14;0)
Изменено: gling - 27 Фев 2015 23:49:54
Страницы: 1
Читают тему (гостей: 1)