Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск первого ненулевого значения в массиве
 
Добрый день, прошу помощи!
у меня схожая тема по поиску первого ненулевого значения в массиве http://www.planetaexcel.ru/forum/index.php?PAGE_NAME=message&FID=8&TID=12073&MID=97584#message97584, но задаче немного сложнее - необходимо чтобы диапазон был динамическим, т.е., например, в формуле ниже добавить опцию смещения диапазона на нужное значение. (сам не смог добавить это)

Спасибо!
Код
=ИНДЕКС(A1:L1;ПОИСКПОЗ(1=1;A2:L2>0;)
Изменено: medvedevdmiana - 2 Мар 2015 11:38:54
 
Смещать куда? В неизвестность?
Файл с примером и результатом будет?

Ссылка в сообщении ведет на страницу форума с перечнем тем.
 
Ссылку исправил. К сожалению, не могу сейчас приложить файл (на работе нет такой возможности), но попробую объяснить. Я ищу первое ненулевое значение (кол-во проданных товаров, например) в массиве для объекта 1, 2...n. В итоге формула выдает значение даты, которая соответствует первому ненулевому значению для определённого объекта.
объект 1объект 2 объект n
дата 1 продажи11 продажи12
дата 2  продажи21  продажи22  
дата n  
Изменено: medvedevdmiana - 2 Мар 2015 12:26:27
 
=МИН(ИНДЕКС(A1:L1;ПОИСКПОЗ(1=1;A2:L2>0;)))
Вводится, как формула массива, тремя клавишами
 
Возможно я что-то не понимаю, но где в условии возможность менять диапазон (смещать) для подходящего объекта (расположены в строках) т.е. A2:L2 в соответвии с данными объекта 1,2..n?
 
Цитата
значение даты, которая соответствует первому ненулевому значению для определённого объекта.
Как это можно осуществить в Вашей таблице? Даты расположены в строках, в которых данные по всем объектам, Вам нужен определенный?
 
Попробую объяснить подробнее:
Для каждого объекта (1,2..n) необходимо получить дату (1.2...n), когда продажи в первый раз стали не равны нулю.

Таблица, которую необходимо сформировать:
Объект первая дата, когда не ноль
объект_1 дата_3
объект_2 дата_1
объект_3 дата_3
Таблица продаж (исходные данные тянутся отсюда):
объект_1 объект_2 объект_3 объект_n
дата_1 0 1 0 1
дата_2 0 0 00
дата_3 3 2 0 5
дата_n 5 1 8 1
Изменено: medvedevdmiana - 2 Мар 2015 13:45:02
 
По картинкам и объясниениям на пальцах не совсем понятно но может угадал
Лень двигатель прогресса, доказано!!!
 
Огромное спасибо!
Страницы: 1
Читают тему (гостей: 1)