Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Преобразование таблицы из формата группировок в классический формат
 
Добрый день! Знающие люди, подскажите, возможно ли преобразовать таблицу без макросов из вида с группировками в классический вид как указано в примере?
 
Добрый день.
Код
=ЕСЛИОШИБКА(ВПР(E$2;СМЕЩ($A$1;ПОИСКПОЗ($D3;$A$1:$A$93;0);0;ПОИСКПОЗ($D4;$A$1:$A$93;0)-ПОИСКПОЗ($D3;$A$1:$A$93;0)-1;2);2;ЛОЖЬ);"")
В Е3 вставить и тянуть вправо. Потом тянуть вниз до "услуга 20".
Добавьте еще в самом низу "услуга 22" - чтобы 21 услуга отображалась (чтобы единая формула была, а то для последней услуги надо менять формулу)

З.Ы. и в целевой таблице измените наименование услуг - между "услуга" и ее номером должен быть пробел, как в исходной таблице.
Кому решение нужно - тот пример и рисует.
 
Спасибо за идею, но формула почему-то не срабатывает...
 
А у меня почему срабатывает?
Изменено: Пытливый - 2 Мар 2015 13:44:23
Кому решение нужно - тот пример и рисует.
 
Спасибо!
Страницы: 1
Читают тему (гостей: 1)