Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вложение нескольких аргументов в формулу
 
Здравствуйте знатоки Excel. Создаю дневник трейдера и столкнулся с такой задачей. При расчете прибыли нужно производить расчет учитывая направление позиции, т.е. BUY или SELL . В первом случае нужно от цены закрытия отнять цену открытия сделки, а во втором от цены открытия отнять цену закрытия сделки. То есть в формуле нужно указать аргумент при котором будет производится тот или иной расчет. Формулу написал, но она работает только с одним аргументом SELL, а есть еще SELL STOP и SELL LIMIT , добавляю эти аргументы в формулу и она перестает работать. Подскажите пожалуйста, как правильно добавить эти три аргумента, чтобы формула работала. Файл прилагаю  
 
combo, В ЛОЖЬ по Если вкладываете другое ЕСЛИ и т.д. =ЕСЛИ(B3="SELL";F3-E3;ЕСЛИ(B3="SELL LIMIT";"SELL LIMIT";E3-F3))
Работать надо не 12 часов, а головой.
 
как вариант
Код
=ЕСЛИ(НЕ(ЕОШ(ПОИСК("SELL";B2;1)>0));F2-E2;E2-F2)
Лень двигатель прогресса, доказано!!!
 
Leanna, спасибо, за подсказку, все заработало!
Страницы: 1
Читают тему (гостей: 1)