Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Определение первого и последнего ненулевого значения
 
Здравствуйте еще раз ))

У меня еще один не сложный вопрос: как в диапазоне найти первое и последнее ненулевое значение. На форуме есть несколько подобных тем: http://www.planetaexcel.ru/forum/index.php?PAGE_NAME=message&FID=1&TID=58916&TITLE_SEO=58916-poisk-p...
http://www.planetaexcel.ru/forum/index.php?PAGE_NAME=message&FID=8&TID=19979&TITLE_SEO=19979&MID=176...
http://www.planetaexcel.ru/forum/?PAGE_NAME=read&FID=8&TID=28956
Я их прочитал, но не смог применить к своему простому примеру. Помогите пож-ста.
 
Код
=ИНДЕКС($A$3:$L$3;МИН(ЕСЛИ($A$3:$L$3<>0;СТОЛБЕЦ($A3:$L3))))
=ИНДЕКС($A$3:$L$3;МАКС(ЕСЛИ($A$3:$L$3<>0;СТОЛБЕЦ($A3:$L3))))
F1 творит чудеса
 
Максим Зеленский, формулы не работают.
 
iskander_s77, ссылки ведут к перечню тем
 
iskander_s77, формулы массивные, Ctrl-Sh-Ent
F1 творит чудеса
 
Максим Зеленский, спасибо. У меня еще вопрос: данные формулы разве определяют первого и последнего? не мин и макс?
 
МИН(...;СТОЛБЕЦ($A3:$L3)
Понятно?
 
vikttur, не понятно
 
Первое ненулевое значение содержится в первом по порядку столбце из содержащих ненулевые значения. Этот столбец имеет наименьший номер среди прочих
Код
ЕСЛИ($A$3:$L$3<>0;СТОЛБЕЦ($A3:$L3))
возвращает массив номеров столбцов, содержащих ненулевые значения в 3 строке, или ЛОЖЬ
Код
МИН(ЕСЛИ(...))
возвращает минимальный номер столбца (игнорируя значения ЛОЖЬ), из массива, полученного на предыдущем этапе
Код
=ИНДЕКС($A$3:$L$3;МИН(...)))
возвращает значение из диапазона $A$3:$L$3, соответствующее определенному на предыдущих этапах номеру столбца
F1 творит чудеса
 
Максим Зеленский, подскажите пож-ста, во вложенном примере ваши формулы работают прекрасно - меняю данные - четко определяют первый и последний. Но подтянул формулы в свою рабочую базу - и ничего.. (( Последний вообще не определяет, а первый частично. В чем проблема?
 
Максим, я попытался применить ваши формулы в свой файл и вот что получилось. Не понимаю.
 
Диапазон в ИНДЕКС со столбца 3, номер наименьшего столбца - тоже 3!
Если нужное значене находится в первом столбце диапазона (столбце С), формула покажет не 1 - столбец-то третий!
Поэтому: или задавать диапазон для ИНДЕКС со столбца А, или уменьшать номер столбца
СТОЛБЕЦ(C4:N4)-2
 
vikttur, спасибо вам большое! понял! ))
Страницы: 1
Читают тему (гостей: 1)