Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как использовать функцию "если", чтобы плюсы и минусы проставлялись автоматически
 
Условия задачи: зеленым цветом отмечены баллы, набираемые при психологическом тесте на аффиляцию. Баллы в этих строках могут распологаться не обязательно в том порядке, в котором обозначенно в таблице. Плюсы и минусы в таблице означают совместимость или несовместимость помошника и машиниста. Например: если машинист набирает 0 баллов то у помошника может быть не больше 5 баллов. Если машинист набирает 1 балл, то у помошника может быть не больше 6 баллов. А если машинист набирает 6 баллов, то помошник может иметь от 1 до 11 баллов. И тд. Таким образом задача состоит в том, чтобы автоматизировать процесс отображения совместимости. Говоря проще - плюсы и минусы должны проставляться автоматически. ОГРОМНОЕ человеческое спасибо заранее.
Изменено: Aliksmir - 5 Мар 2015 00:16:30
 
А если машинист набирает 15 баллов? А 10? А 17? Тогда какие критерии для отображения+/-?
Кому решение нужно - тот пример и рисует.
 
если машинист набирает 15, то у помошника может быть от 5 до 15. Т.е. получается что разница должна быть в 5 баллов. Там в таблице я поспешил и не проставил для примера плюсики и минусы. Исправил. Наглядно будет понятнее
 
смотрите файл, проверяйте.
 
Получилось!!! Спасибо тебе, друг! Моя проблема решена! Если не секрет, то как выглядет логическое выражение на словах?
Изменено: Aliksmir - 4 Мар 2015 14:35:14
 
Как вариант:
Код
=ЕСЛИ(ABS(B1-C1)<=5;"+";"-")

 
Вариант без ЕСЛИ
Код
=ИНДЕКС({"-";"+"};(ABS(B1-C1)<=5)+1)
Изменено: МВТ - 4 Мар 2015 23:46:23
 
А можно и при помощи формата ячейки или условного форматирования :) сократив до
Код
=ABS(B1-C1)<=5
F1 творит чудеса
Страницы: 1
Читают тему (гостей: 1)