Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчёт данных по первоначальным символам описания.
 
Добрый день.

Пожалуйста подскажите, как запустить формулу: =СУММЕСЛИ('S+N'!B:B;ЛЕВСИМВ('S+N'!B:B;ДЛСТР(B3)=B3);'S+N'!F:F)
'S+N' - лист с которого берутся данные
Проверяемые данные - столбец В:В, суммируемые - столбец F:F
Условие для суммирования: должны совпадать начальные названия описания.
Начальные описания находятся на другом листе в колонке В:В
Загвоздка в условии: ЛЕВСИМВ('S+N'!B:B;ДЛСТР(B3)=B3), т.е. на листе 'S+N' я пытаюсь найти данные у которых начальные значения будут совпадать с данными таблицы на рабочем листе.
 
так попробуйте
Код
=СУММПРОИЗВ((ЛЕВСИМВ('S+N'!$B$4:$B$1721;ДЛСТР($B8))=$B8)*('S+N'!$G$4:$G$1721=I$7)*'S+N'!$F$4:$F$1721)
Лень двигатель прогресса, доказано!!!
 
В принципе работает, но....
В этой формуле указана последняя строка данных - 1721. Если поставить номер любой другой строки ниже, то выдаёт #Н/Д
Лист 'S+N' может содержать до 100 тыс. строк.
Т.е. прийдется каждый раз редактировать формулу и "протягивать" её на все виды.

Спасибо!
Изменено: SNMel - 5 Мар 2015 11:27:07
 
если ваши сокращенные наименования вынести в доп столбец то можно и суммесли и счетесли, с мотрите в файле, файл подрезан что бы влез сюда
Лень двигатель прогресса, доказано!!!
 
Цитата
SNMel написал: я пытаюсь найти данные у которых начальные значения будут совпадать с данными таблицы на рабочем листе.
Так, что ли, надо?
Код
=СУММЕСЛИ('S+N'!$B:$B;B12&"*";'S+N'!$F:$F)
=СЧЁТЕСЛИ('S+N'!B:B;B9&"*")
 
тут косячки могут быть в подсчетах HYPERION SB и HYPERION
Лень двигатель прогресса, доказано!!!
 
Да через СЧЁТЕСЛИ('S+N'!B:B;B8&"*") косяк возникает, но не пойму почему.
Через замену поменял в книге похожие наименования.
По Пацифик PRO и Пацифик Минерал считает правильно, по HYPERION - нет.
Изменено: SNMel - 5 Мар 2015 13:05:25
Страницы: 1
Читают тему (гостей: 1)